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UNIT 1 

Introduction 

A computer is a general purpose device that can be programmed to carry out a set of arithmetic or 

logical operations automatically.  

A computer is an electronic device that manipulates information, or data. It has the ability 

to store, retrieve, and process data. You can use a computer to type documents, send email, and 

browse the Web. You can also use it to handle spreadsheets, accounting, database management, 

presentations, games, and more. 

In World War II, mechanical analog computers were used for specialized military applications. 

During this time the first electronic digital computers were developed. Computer was developed by 

CHARLES BABBAGE. He is also known as Father of computers. 

All types of computers consist of two basic parts: 

 Hardware is any part of your computer that has a physical structure (Tangible), such as 

the computer monitor or keyboard. 

 

 Software is any set of instructions that tells the hardware what to do. It is what guides the 

hardware and tells it how to accomplish each task. Some examples of software include web 

browsers, games, and word processors such as Microsoft Word. 

 

 

   

  

 

 

 

 

 

 

Organization of a Computer 

Computer can also be defined in terms of functions it can perform. A computer can 

i) Accept data,  

ii) Store data,  

iii) Process data as desired,  

iv) Retrieve the stored data as and when required and  

v) Print the result in desired format. 

 

Characteristics of computer:- 

 Speed 

 Accuracy 

 Power of Remembering 

 Diligence 

 Versatility 

 No IQ 

 No Feeling 

 Storage 

Output Unit          Processing Unit      INPUT

  

     Memory 
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Block diagram of Computer:- 

 

 
 

 

1. Input: this is the process of entering data and programs into the computer system. 

2. Control Unit (CU): The process of input, output, Control Unit (CU): The process of input, 

output, processing and storage is performed under the supervision of a unit called 'Control 

Unit'. It decides when to start receiving data, when to stop it, where to store data, etc. It takes 

care of step -by-step processing of all operations inside the computer. 

3. Memory Unit: Computer is used to store data and instructions. 

4. Arithmetic Logic Unit (ALU): The major operations performed by the ALU are addition, 

subtraction, multiplication, division, logic and comparison. 

5. Output: This is the process of producing results from the data for getting useful information. 

The ALU and the CU of a computer system are jointly known as the central processing unit 

(CPU). You may call CPU as the brain of any computer system. 

 

Basic application of Computer 

 Word Processing 

 Internet 

 Digital video or audio composition 

 Desktop publishing 

 Computers in Medicine 

 Mathematical Calculations 

 Banks 

 Travel 

 Telecommunications 

 Defense 

 E-Learning 

 Business 
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A motherboard is the main printed circuit board (PCB) found in general 

purpose microcomputers and other expandable systems. It holds and allows communication between 

many of the crucial electronic components of a system, such as the central processing unit (CPU) 

and memory, and provides connectors for other peripherals. A motherboard usually contains 

significant sub-systems such as the central processor, the chipset's input/output and memory 

controllers, interface connectors, and other components integrated for general purpose use. 

Motherboard specifically refers to a PCB with expansion capability and as the name suggests, this 

board is often referred to as the "mother" of all components attached to it, which often 

include peripherals, interface cards, and sound cards, video cards, network cards, hard drives, or 

other custom components. 

Computer Hardware: 

In simple terms we can say, computer parts that have tangible property are comes under computer 

hardware categories. Computer hardware is the physical parts or components of a computer.  This is 

also sometime called the machinery or the equipment of the computer. 

 

Computer Software:  

Computer software is instructions that can be stored and run by hardware. Software is any set of 

machine-readable instructions that directs a computer's processor to perform specific operations.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 Insurance 

 Banking 

 Business 

 Education 

 Marketing 

 Health Care 

 Engineering Design 

 Military 

 Communication 

 Government Applications 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The various applications of Computers:- 
 

Computer 
Software 

Hardware 

https://en.wikipedia.org/wiki/Printed_circuit_board
https://en.wikipedia.org/wiki/Microcomputer
https://en.wikipedia.org/wiki/Central_processing_unit
https://en.wikipedia.org/wiki/Computer_memory
https://en.wikipedia.org/wiki/Peripherals
https://en.wikipedia.org/wiki/Printed_circuit_board
https://en.wikipedia.org/wiki/Peripheral
https://en.wikipedia.org/wiki/Sound_card
https://en.wikipedia.org/wiki/Video_card
https://en.wikipedia.org/wiki/Network_card
https://en.wikipedia.org/wiki/Hard_drive
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Input devices 

 

 

 

 

Input devices 

 

An input device is an electromechanical device as it utilizes both electronic and mechanical power. 

It aims in receiving data from external world. The input devices are responsible for converting data 

into a form that is understood by the computer. An input device is a peripheral device that converts 

symbols that people understand into bits that computers can process 

  

Basic working of input devices:- 

 

 Accept the data. 

 Convert it into the machine understandable form. 

 

Computer Hardware 
- 

Input devices 
Output devices 
 

Storage device Processor 
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Different Types of input devices:-  

 

 Keyboard 

 Mouse 

 Joystick 

 Light pen 

 Track Ball 

 Scanner 

 Graphic Tablet 

 Microphone 

 Magnetic Ink Card Reader (MICR) 

 Optical Character Reader (OCR) 

 Bar Code Reader 

 Optical Mark Reader 

 

 

 

Keyboard 

Keyboard is one of the most commonly used input devices to input the date into the computer. It is 

like the traditional typewriter, although there are some additional keys provided for performing some 

additional functions. Keyboards are of two sizes 84 keys or 101/102 keys, but now 104 keys or 108 

keys. 

 

 Keyboard is an input device used to enter data in to computer by pressing one key at one 

time. 

 It has its own processor and circuitry that carries information to the processor. 

 When you press a key, it presses a switch, completing the circuit and allowing a tiny amount 

of current to flow through. 

 It tells the processor the position of each key what each keystroke or combination of 

keystrokes represents. 

 
 Despite the development of alternative input devices, such as mouse, touch screen, light 

pen, the keyboard remains the most commonly used and most versatile device used for direct 

(human) input into computers. 

 One factor determining the size of a keyboard is the presence of duplicate keys, such as a 

separate numeric keyboard, for convenience. 

  Another factor determining the size of a keyboard is the size and spacing of the keys. 

 

Generally the keyboards contain the following keys, they are:- 
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 Alphabets 

 Arithmetic operators such as +, -, *, / 

 Numeric digits 0–9 

 Cursor arrow keys 

 Navigation keys such as Home, End, PgUp, PgDown, etc. 

 Num Lock button, used to enable or disable the numeric pad.  

 Enter key 

 

The following are the different layouts of the keyboards, they are as follows 

 QWERTY 

 QWERTZ 

 AZERTY  

 DVORAK 

 

Mouse: 

The mouse is used to point to a particular place on the screen and select to perform one or more 

action. The pointing device may point to the menu, commands, size windows, starts programs etc. 

The most conventional kind of mouse has two buttons on top: the left one being used most frequently 

then right one. A mouse is a pointing device that functions by detecting 2D motion relative to its 

supporting surface. The mouse's motion typically translates into the motion of a pointer on a display, 

which allows for fine control of a graphical user interface 

 

Mouse Actions 

 Left Click  

 Double Click  

 Right Click  

 Drag and Drop 

 

Types of mouse:- 

 

 Mechanical mouse: Houses a hard rubber ball that rolls as the mouse is moved. Sensors 

inside the mouse body detect the movement and translate it into information that the 

computer interprets. 

 Optical mouse: Uses an LED sensor to detect tabletop movement and then sends off that 

information to the computer for merry munching. 

 Cordless 3-D mouse: This kind of mouse can be pointed at the computer screen like a TV 

remote 

 Wireless Mouse: Wireless mouse works via radio frequencies commonly referred to as RF. 

RF wireless mouse requires two components to work properly – a radio transmitter and a 

radio receiver. 

RF Transmitter: A radio frequency (RF) transmitter is usually integrated inside the mouse. 

The mouse records its movements and buttons that are clicked and then sends this 

information via radio signals to the receiver. 

RF Receiver: The radio frequency (RF) receiver usually connects to the computer‘s 

peripheral mouse input. It receives these RF signals, decodes them, and then sends these 

signals directly to the computer as normal. 
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                 Mechanical Mouse     Wireless Mouse 

 

Track ball: 

This is also a pointing device. Track ball is an input device that is mostly used in notebook or laptop 

computer, instead of a mouse. This is a ball, which is half inserted and 

by moving fingers on ball, pointer can be moved. Since the whole 

device is not moved, a track ball requires less space than a mouse. A 

track ball comes in various shapes like a ball, a button and a square.  

 

Compared with a mouse, a trackball has no limits on effective travel; 

at times, a mouse can reach an edge of its working area while the 

operator still wishes to move the screen pointer farther. With a 

trackball, the operator just continues rolling, whereas a mouse would 

have to be lifted and re-positioned. 

 

 

Joystick:- 

The joystick is handheld stick. This stick can rotate about one end 

transmitting its angle to the computer in two or three dimensions. It 

typically has a button on top that is used to select the option pointed by the 

cursor.  

Joysticks are often used to control video games, and usually have one or 

more push-buttons whose state can also be read by the computer. 

 

Elements in a Joystick 

 Stick  

 Base 

 Trigger 

 Extra button 

 Autofire 

switch 

 Throttle 

 Hat switch 

 Suction cup 

 

 

Digitizing Tablet: 
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An input device that permits drawing of images and graphics is called a digitizing tablet. They give 

feeling of drawing images with pencil and paper. The graphics tablet has two major parts that are:- 

 A flat surface on which the image is drawn.  

 Stylus that helps in drawing. 

 

 

Scanners 

An input device capable to read text or illustrations printed on a paper and 

interpret it in a form that can be used by a computer is known as a 

scanner. It converts the document image into digital form so that it can be 

fed into the computer. Capturing information like this reduces the 

possibility of errors typically experienced during large data entry. 

 

Digital Camera 

A digital camera can store many more pictures than an ordinary camera. Pictures taken using a 

digital camera are stored inside its memory and can be transferred to a computer by connecting the 

camera to it. A digital camera takes pictures by converting the light passing through the lens at the 

front into a digital image. 

There are several categories in which the cameras can be classified:- 

 Video camera  

 Professional video cameras 

 Camcorders used by amateurs. 

 webcams  

 Digital camera 

 Live-preview digital cameras 

 Compact digital cameras 

 Bridge cameras 

 

 

 

 

 

Magnetic Ink Character Recognition: 

 

 
MICR is also an input device is commonly used in banks because of a large number of cheques to be 

processed. The bank's code number and cheque number are printed on the cheques with a special 

type of ink that contains particles of magnetic material that are machine readable. This reading 

process is called Magnetic Ink Character Recognition (MICR).  
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Magnetic Ink Character Recognition is a character recognition system that uses special ink and 

characters. When a document that contains this ink needs to be read, it passes through a machine, 

which magnetizes the ink and then translates the magnetic information into characters. 

 

MICR technology is used by banks. Numbers and characters found on the bottom of checks (usually 

containing the check number, sort number, and account number) are printed using Magnetic Ink. To 

print Magnetic Ink need, you need a laser printer that accepts MICR toner. 

MICR provides a secure, high-speed method of scanning and processing information. 

 

Optical character Reader:-  
Optical character Reader is an input device that is use to read a printed text. The OCR 

scans text optically character by character, converts them into a computer readable code 

and stores the text on the system memory.  

 

Optical Mark Reader:- 

Optical mark reader is also known as optical mark recognition that is same as the scanner which 

reads on specific areas of the page. Thus OMR can be defined as the process of scanning paper-based 

documents and identify data or marks in a location defined previously. 

It is specially used for checking the answer sheets of examinations having multiple choice questions. 

 

Bar Code Reader:- 

An electronic device used to read barcodes printed on various surfaces is called 

barcode reader. It is also known as barcode scanner. Bar Code Reader scans a bar 

code image, converts it into an alphanumeric value, which is then fed to the 

computer to which bar code reader is connected. 

Bar coded data is generally used in labeling goods, numbering the books, etc. It 

may be a hand-held scanner or may be embedded in a stationary scanner. 

 

Voice Recognition System:- 

Voice recognition systems are alternatively known as voice data entry or audio data entry terminals. 

This method of input enables a programmer to instruct the computer with spoken words instead of a 

written program 

 

 

Light Pen:- 

Light pen is also an input device used as pointing device, 

which is similar to a pen. It is used to select a displayed 

menu item or draw pictures on the monitor screen. It 

consists of a photocell and an optical system placed in a 

small tube. 

When light pen's tip is moved over the monitor screen and 

pen button is pressed, its photocell sensing element detects 

the screen location and sends the corresponding signal to 

the CPU. 

 A light pen is a computer input device used in conjunction with a computer's CRT display. 
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 It allows the user to point to displayed objects or draw on the screen in a similar way to 

a touch screen but with greater positional accuracy. 

 A light pen detects a change of brightness of nearby screen pixels when scanned by cathode 

ray tube electron beam and communicates the timing of this event to the computer. 

 Because the user is required to hold his arm in front of the screen for long period of time, the 

light pen fell out of use as a general purpose input device. 

Touch screen:- 

An input device that permits users to operate a PC by simply touching the display screen is called a 

touch screen. The touch screen is as easy to use as trackballs or touchpad‘s. 

Three major components form a basic touch screen they are as follows:- 

 Touch sensor 

 Controller 

 Software driver 
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Output Devices 

 

 

An output is an electromechanical device that receives output from a computer in binary coded form 

and converts it into human understandable form and transmits to the user. An output device is 

any peripheral that receives data from a computer, usually for display, projection, or physical 

reproduction. 

 Monitor / Visual Display Unit 

 Printer 

 Plotter 

 Speaker 

 

Monitor: 

Monitor is the most common and the most popular output device.  It forms images from tiny dots, 

called pixels that are arranged in a rectangular form. The sharpness of the image depends upon the 

number of the pixels. 

 

There are two types of viewing screen used for monitors: 

 

 Cathode-Ray Tube (CRT):  

The CRT display is made up of small picture elements called pixels. The smaller 

the pixels, the better the image clarity, or resolution. It takes more than one 

illuminated pixel to form whole character, such as the letter ‗e‘ in the word help. 

 There are some disadvantages of CRT: 

 Large in Size 

 High power consumption 

 

 Flat-Panel Display Monitor 

The flat-panel display refers to a class of video devices that have reduced volume, weight and 

power requirement in comparison to the CRT. You can hang them on walls or wear them on your 

wrists. Current uses of flat-panel displays include calculators, 

video games, monitors, laptop computer, graphics display. 

 

The flat-panel display is divided into two categories: 

 Emissive Displays - The emissive displays are devices 

that convert electrical energy into light. Example are plasma 

panel and LED(Light-Emitting Diodes). 

 Non-Emissive Displays - The Non-emissive displays 

use optical effects to convert sunlight or light from some other 

source into graphics patterns. Example is LCD(Liquid-Crystal 

Device) 

 

 

 

Classification- Based on Signals: 

 Digital Monitor 

 Analog Monitor 
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Classification- Based on Picture Quality 

 VGA 

 SVGA 

 XGA 

 

Printer:- 

A printer is an output device that is used in a computer to print alphanumeric characters on papers. It 

converts the electronic signals from the computer into human readable form or hardcopy to produce 

a print out of the result of data processed in the computers. 

Printers are broadly classified in to two categories:- 

 

Impact printers: 

An impact printer has mechanisms resembling those of a typewriter. It forms characters or images 

by striking a mechanism such as a print hammer or wheel against an inked ribbon, leaving an 

image on paper. 

 

 Character Printer:-  

Impact printers are dying out; however, you may still come in contact with a dot-matrix printer. 

A dot-matrix printer contains a print head of small pins that strike an inked ribbon, forming 

characters or images. Print heads are available with 9, 18, or 24 pins; the 24-pin head offers 

the best print quality. 

 Dot-matrix printers permit a choice between output of draft quality; a coarser-looking 72 dots 

per inch vertically, which may be acceptable for drafts of papers and reports, and near-letter-

quality, a crisper-looking 144 dots per inch vertically, which is more suitable for a finished 

product to be shown to other people. 

 

 Dot-matrix printers print about 40-300 characters per second (cps) and can print some 

graphics, although the reproduction quality is poor. Color ribbons are available for limited 

use of color. Dot-matrix printers are noisy, inexpensive, and they can print through multipart 

forms, creating several copies of a page at the same time,  

 

 Dot-Matrix Printer 

 Daisy-Wheel Printer 

 Line printer 

 Drum Printer 

 Chain Printer 

 Non-Impact printers 

  Ink-Jet Printer 

   Laser Printer 

 

Plotter:- 

A plotter is a vector graphics printing device that connects to a computer. It draws pictures on paper 

based on commands from computer. A plotter is a very versatile tool. 

 

Types of plotters:- 

 Drum plotter 
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 Flat-Bed plotter 

 

Sound Cards:- 

Sound cards are a important part of computer, without sound cards you will have no music, no 

effects and no voices. Sound card is also referred as a sound board or an audio card, a sound 

card is an expansion card or integrated circuit that provides a computer with the ability to produce 

sounds that can be heard by the user either over speakers or headphones.  

Sound card connections are as follows:- 

 Digital out 

 Sound in or line in 

 Microphone or Mic 

 Sound out or line out 

 Fire wire 

 MIDI or Joystick 

 

Speakers:- 

 

 A hardware device that is connected to a computer's sound card that outputs sounds generated by 

the computer is referred as speaker. Speakers are rated in Frequency response, Total Harmonic 

Distortion, and Watts.  

 

Storage:- 

Computer data storage is often known as storage or memory refers to computer components and 

recording media that retain digital data used for computing for some interval of time. A memory is 

just like a human brain. It is used to store data and instructions. Computer memory is the storage 

space in computer where data is to be processed and instructions required for processing are stored. 

Memory is primarily of two types: 

 Primary Memory/Main Memory 

 Secondary Memory 

 

Primary memory:- 

Primary memory holds only those data and instructions on which computer is currently working. It 

has limited capacity and data gets lost when power is switched off. It is generally made up of 

semiconductor device. These memories are not as fast as registers. The data and instructions required 

to be processed earlier reside in main memory. Primary memory is divided into two categories they 

are as follows:- 

 RAM 

 ROM. 

 

RAM:- 

Full form of  RAM random access memory (RAM). A RAM constitutes 

the internal memory of the CPU for storing data, program and program 

result. It is read/write memory. Since access time in RAM is independent 

of the address to the word that is, each storage location inside the 

memory is as easy to reach as other location & takes the same amount of 

time 

RAM is volatile, i.e., data stored in it is lost when we there is a power 
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failure. Hence, a backup uninterruptible power system (UPS) is often used with computers. RAM is 

small, both in terms of its physical size and in the amount of data it can hold. 

There are two types of RAM they are as follows:- 

 Static RAM (SRAM)  

 Dynamic RAM (DRAM) 

Static RAM (SRAM) 

 

 The word static indicates that the memory retains its contents as long as power remains 

applied.  

 Data is lost when the power gets down due to volatile nature.  

 SRAM chips use a matrix of 6-transistors and no capacitors.  

 Transistors do not require power to prevent leakage, so SRAM need not have to be refreshed 

on a regular basis. 

 Because of the extra space in the matrix, SRAM uses more chips than DRAM for the same 

amount of storage space, thus making the manufacturing costs higher. 

 Static RAM is used as cache memory needs to be very fast and small. 

 

Characteristic of the Static RAM 

 It has long data lifetime 

 There is no need to refresh 

 Faster 

 Used as cache memory 

 Large size 

 Expensive 

 High power consumption 

 

Dynamic RAM (DRAM) 

 DRAM must be continually refreshed in order to maintain the data.  

 This is done by placing the memory on a refresh circuit that rewrites the data several hundred 

times per second. 

 DRAM is used for most system memory because it is cheap and small.  

 All DRAMs are made up of memory cells.  

 These cells are composed of one capacitor and one transistor. 

 

Characteristic of the Dynamic RAM 

 It has short data lifetime 

 Need to refresh continuously 

 Slower as compared to SRAM 

 Used as RAM 

 lesser in size 

 Less expensive 

 Less power consumption 

 

ROM:- 

ROM is Read Only Memory. ROM are the memories on which it is 

not possible to write the data when they are online to the computer. 

They can only be read. It is a permanent in built in the computer at 

the time of its production. It is also known as firmware. It stores 

the set of instructions permanently which instructs the computer 
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how to work. The ROM can be used in storing micro programs, system programs, subroutines. 

Types of ROM are as follows:- 

 PROM 

 EPROM 

 EEPROM 

 

MROM (Masked ROM) 

 The very first ROMs were hard-wired devices that contained a pre-programmed set of data or 

instructions.  

 These kinds of ROMs are known as masked ROMs.  

 It is inexpensive ROM. 

PROM (Programmable Read only Memory) 

 PROM is read-only memory that can be modified only once by a user.  

 The user buys a blank PROM and enters the desired contents using a PROM programmer.  

 Inside the PROM chip there are small fuses which are burnt open during programming.  

 It can be programmed only once . 

 It is not erasable. 

 

EPROM(Erasable and Programmable Read Only Memory) 

 The EPROM can be erased by exposing it to ultra-violet light for duration of up to 40 

minutes.  

 During programming an electrical charge is trapped in an insulated gate region.  

 The charge is retained for more than ten years because the charge has no leakage path.  

 For erasing this charge, ultra-violet light is passed through a quartz crystal window (lid). 

 This exposure to ultra-violet light dissipates the charge.  

 During normal use the quartz lid is sealed with a sticker. 

 

EEPROM(Electrically Erasable and Programmable Read Only Memory) 

 The EEPROM is programmed and erased electrically.  

 It can be erased and reprogrammed about ten thousand times.  

 Both erasing and programming take about 4 to 10 ms (milli second).  

 In EEPROM, any location can be selectively erased and programmed. 

 EEPROMs can be erased one byte at a time, rather than erasing the entire chip. 

 Hence, the process of re-programming is flexible but slow. 

 

UVEPROM(Ultra Violet Erasable and Programmable Read Only Memory) 

 The UVEPROM is programmed and erased using ultra Violet rays.  

 It can be erased and reprogrammed about ten thousand times.  

 Both erasing and programming take about 4 to 10 ms (milli second).  

 

Advantages of ROM 

 Non-volatile in nature 

 These cannot be accidentally changed 

 Cheaper than RAMs 

 Easy to test 

 More Reliable than RAMs 

 These are static and do not require refreshing 

 Its contents are always known and can be verified 
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Secondary memory:- 

Secondary memory is also known as external memory or non-volatile. It is slower than primary 

memory. These are used for storing Data/Information permanently the data one stored will not be 

erased as the power is switched off. CPU directly does not access these memories, instead they are 

accessed via input-output routines. Contents of secondary memories are first transferred to main 

memory and then CPU can access it.  

Types of secondary memory are as follows:- 

 Magnetic tapes 

 Magnetic disk 

 

Magnetic tapes:- 

Magnetic tape is the most commonly used device for storing large data. It is sequential access 

device. Magnetic tape is a strip or ribbon of plastic which is coated with Ferro magnetic oxides. It is 

generally 80-2400 feet long and ½ inch wide, in size. 

 

Magnetic Disk:- 

A magnetic disk is a circular plate constructed of metal or plastic coated with magnetized material. 

Both sides of the disk are used and several disks may be stacked on one spindle with read/write 

heads available on each surface. Bits are stored in magnetized surface in spots along concentric 

circles called tracks. Tracks are commonly divided into sections called sectors. Disk that are 

permanently attached and cannot removed by occasional user are called hard disks. A disk drive with 

removable disks is called a floppy disk drive. 

 

Types of magnetic disk:- 

 Hard disk 

 Floppy disk 

 Compact disk 

 Video CD 

 DVD 

Floppy Disk 

The floppy disk gets its name from the fact that it is made out of a flexible plastic material. The 

plastic base is coated with an iron-oxide recording substance that's similar to the material applied to 

the plastic ribbon of a magnetic tape. Data are recorded as tiny invisible magnetic spots on this 

coating.  

CD-ROM 

The CD-ROM (Compact Disk Read Only Memory) is a direct extension of audio CD. CD-ROM 

players are more rugged and have error correction facility. This ensures proper data transfer from 

CD-ROM to the RAM of the computer. CD-ROM is written using a CD writer. Information is 

retrieved from a CD-ROM using a low power laser, which ingenerate in an on optical disk drive 

unit.  

Hard Disk 

The disk described so far is the type of disks which can be removed from the disk drive and carried 

from place to place. Some disks however, are built into the computer or a special disk drive.. Hard 

disks can store anywhere from 20 MB to more than 40GB. Hard disks are also from 10 to 100 times 

faster than floppy disk. 
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USB drive (1) An external hard disk drive or optical disc drive that plugs into the USB port. 

portable hard drive. (2) A solid state storage module that plugs into the computer's USB port. Using 

flash memory chips that hold up to one terabyte of data, the solid state USB drive emulates a hard 

disk. 

A USB flash drive -- also known as a USB stick, USB thumb drive or pen drive -- is a plug-and-play 

portable storage device that uses flash memory and is lightweight enough to attach to a keychain. A 

USB flash drive can be used in place of a compact disc. 

 

Cache Memory 

Cache memory is faster than the main memory. The cache memories although are fast yet are very 

expensive memories and are used in only small size. Thus, small cache memories are intended to 

provide fast speed of memory retrieval without sacrificing the size of memory. Cache memory stores 

a copy of the instructions and data to be immediately used of main memory. The memory reads or 

writes operation is first checked with cache memory and if the desired location data is available in 

cache memory then used by the CPU directly. 

 

 

Other Memories:- 

 Flash memory 

 Virtual memory 

 Cache Memory 

 

Software 

Software is a set of program which performs desired task. Software runs on hardware. Software is a 

sequence of instructions written to solve a particular problem. 

There are two types of software‘s: 

 System Software 

 Application Software 

 

System Software:- 

System Software performs the basic functions necessary to start and operate a computer. It refers to 

all programs that make computer work. It controls and monitors the various resources of a computer 

such as processor, input-output devices and communication links. Example : - Operating System and 

Compiler  

 

System software is divided into three categories:- 

 System management software 

 System support software 

 System development software 

 

Application Software:- 

Application software refers to the programs which help the computer to work effectively for specific 

applications. Example Ms- Office , Tally , Adobe etc. 

Application software is of two types:- 

 General purpose program 

 Application specific program 

Other software‘s are as follows:- 
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 Utility software 

 utility software are those software that is used for system utilization . 

like antivirus , window media player etc. 

Virus :-  

A computer virus is a program or piece of code that is loaded onto your computer without you 

knowledge and runs against your wishes. All computer virus are man made. 

A few prominent virus are Michelangelo, dishwasher, C-brain , macmag , nenusalem , columbus  

etc. 

 

Antivirus : - a utility software that searches a hard disk for viruses and removes any that are found. 

Most antivirus programs include an auto update feature that enables the program to download 

profiles of nes virus so that it can check for the new viruses as soon as they are discovered. 

Some popular antivirus are NPAV, Quick heal ,Avast and Mac fee etc. 

 

 

Compiler - Compiler is a system program which translates a high-level language program into 

machine language program is called a compiler. Compiler also checks error of the program to be 

executed. 

 

Features of the compiler:  

Compiler is more powerful than assembler. 

 

Limitation of the compiler: 

 Take longer time to produce result. 

 It occupies more memory space. 

 Low speed and low efficiency of memory utilization. 

 

                                           
 

Interpreter - It is also a translator which translates a high-level language program into object code, 

statement wise. It doesn‘t translate the entire program at a time. It takes up one statement of a high-

level language program at a time, translates it and then executes it and then takes up the next 

statement and repeats the whole process till end. 

Features of the Interpreter: 

 Interpreter is cheaper than compiler. 

 It occupies less memory space. 

 

Limitations of the Interpreter: 

 Slower than compiler. 

 Suitable only for small programs. 
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The difference between an interpreter and a compiler is given below: 

Interpreter Compiler 

Translates program one statement at a time. 
Scans the entire program and translates it as a 

whole into machine code. 

It takes less amount of time to analyze the 

source code but the overall execution time is 

slower. 

It takes large amount of time to analyze the 

source code but the overall execution time is 

comparatively faster. 

No intermediate object code is generated, 

hence are memory efficient. 

Generates intermediate object code which 

further requires linking, hence requires more 

memory. 

Continues translating the program until the 

first error is met, in which case it stops. Hence 

debugging is easy. 

It generates the error message only after 

scanning the whole program. Hence debugging 

is comparatively hard. 

Programming language like Python, Ruby use 

interpreters. 

Programming language like C, C++ use 

compilers. 
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Linker: In high level languages, some built in header files or libraries are stored. These libraries are 

predefined and these contain basic functions which are essential for executing the program. These 

functions are linked to the libraries by a program called Linker.  

If linker does not find a library of a function then it informs to compiler and then compiler generates 

an error. The compiler automatically invokes the linker as the last step in compiling a program. 

Not built in libraries, it also links the user defined functions to the user defined libraries. Usually a 

longer program is divided into smaller subprograms called modules. And these modules must be 

combined to execute the program. The process of combining the modules is done by the linker. 

 

Loader: Loader is a program that loads machine codes of a program into the system 

memory. In Computing, a loader is the part of an Operating System that is responsible for loading 

programs. It is one of the essential stages in the process of starting a program. Because it places 

programs into memory and prepares them for execution. Loading a program involves reading the 

contents of executable file into memory.  Once loading is complete, the operating system starts the 

program by passing control to the loaded program code. All operating systems that support program 

loading have loaders. In many operating systems the loader is permanently resident in memory.  

 
 

 

Languages of Computer:- 

In order to communicate with the computer user also needs to have a language that should be 

understood by the computer. For this purpose, different languages are developed for performing 

different types of work on the computer. Basically, There are three types of computer languages they 

are as follows:- 

 Low level language 

 Assembly level language 

 High level language 

 

Low level language:- 

Low level language is also known as Machine level language. The low level 

language is directly understood by the computer. in other words, the binary 

language is machine language(0s and 1s). any instruction given in the machine 

language has two parts:- 

 OPCODE 
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 OPERAND 

 

Assembly level language:- 

The major drawback of machine language lead to the introduction of a new language called 

assembly level language. A program written in symbolic language is called an assembly code or a 

symbolic program. Assembler translates the assembly code into machine code, it also ―assembles‖ 

the machine code into the main memory of the computer and makes it ready for execution.  

 

 

 

High Level Language:- 

To overcome the difficulties of low level language such as machine dependency, difficult to 

understand etc. high level languages are classified into two types- general and specific purpose high 

level language. 

                                    
 

 

 

Data compression 

Data compression is encoding of information using fewer bits than the original representation. The 

process of reducing the size of a data file is referred to as data compression  

Lossy: Lossy compression reduces bits by removing unnecessary or less important information. 

Lossless: Lossless compression reduces bits by identifying and eliminating statistical redundancy. 

No information is lost in lossless compression.  

Uncompressing (or decompressing) is the act of expanding a compression file back into its original 

form.  It is the reverse process of compression. 

Compression is useful because it reduces resources required to store and transmit data. Data 

compression is subject to a space–time complexity trade-off. For instance, a compression scheme for 

video may require expensive hardware for the video to be decompressed fast enough to be viewed as 

it is being decompressed, and the option to decompress the video in full before watching it may be 

inconvenient or require additional storage.  
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UNIT 2 

 

Operating System 

An operating system is a program that acts as an interface between the user and the computer 

hardware and controls the execution of all kinds of programs. 

In technical terms, it is software which manages hardware. An operating System controls the 

allocation of resources and services such as memory, processors, devices and information. 

 
 

Functions of operating system 

Following are some of important functions of an operating System. 

 Memory Management 

 Processor Management 

 Device Management 

 File Management 

 Security 

 Control over system performance 

 Job accounting 

 Error detecting aids 

 Coordination between other software and users 

 

Memory Management 

Memory management refers to management of Primary Memory or Main Memory. Main memory is 

a large array of words or bytes where each word or byte has its own address.  

Main memory provides a fast storage that can be access directly by the CPU. So for a program to be 

executed, it must in the main memory. Operating System does the following activities for memory 

management. 

 Keeps tracks of primary memory i.e. what part of it are in use by whom, what part are not in 

use. 

 In multiprogramming, OS decides which process will get memory when and how much. 

 Allocates the memory when the process requests it to do so. 

 De-allocates the memory when the process no longer needs it or has been terminated. 
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Process Management 

In multiprogramming environment, OS decides which process gets the processor when and how 

much time. This function is called process scheduling. Operating System does the following 

activities for processor management. 

 Keeps tracks of processor and status of process. Program responsible for this task is known 

as traffic controller. 

 Allocates the processor (CPU) to a process. 

 De-allocates processor when processor is no longer required. 

 

Device Management 

OS manages device communication via their respective drivers. Operating System does the 

following activities for device management. 

 Keeps tracks of all devices. Program responsible for this task is known as the I/O controller. 

 Decides which process gets the device when and for how much time. 

 Allocates the device in the efficient way. 

 De-allocates devices. 

 

File Management 

A file system is normally organized into directories for easy navigation and usage. These directories 

may contain files and other directions. Operating System does the following activities for file 

management. 

 Keeps track of information, location, uses, status etc. The collective facilities are often 

known as file system. 

 Decides who gets the resources. 

 Allocates the resources. 

 De-allocates the resources. 

 

Resource Allocation 

The resources such as CPU, memory, I/O channels are needed by all user jobs, and their allocation is 

handled automatically by the operating system. Some problems to be handled by the operating 

system are: 

- mutual exclusion 

- process synchronization,  

- deadlock avoidance 

- security and protection 

 

Other Important Activities 
Following are some of the important activities that Operating System does. 

 Security -- By means of password and similar other techniques, preventing unauthorized 

access to programs and data. 

 Control over system performance -- Recording delays between request for a service and 

response from the system. 

 Job accounting -- Keeping track of time and resources used by various jobs and users. 

 Error detecting aids -- Production of dumps, traces, error messages and other debugging 

and error detecting aids. 

 Coordination between other software’s and users -- Coordination and assignment of 

compilers, interpreters, assemblers and other software to the various users of the computer 

systems. 
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CUI: character user interface or command-line user interface, CUI is a prompt used to interact 

with computer programs. It works by allowing the user (client) to issue commands as one or 

more lines of text (referred to as command lines) to a program. One of the CUI's uses is that it 

provides an easy way to implement programming scripts. 

The command-line user interface was the primary method of communicating with a computer 

from the first machines, all the way through the 1980s. Although it may still be accessed in most 

of today operating systems, it is utilized far less due to the ease of use and familiarity of the 

graphical user interface (GUI). The CUI, however, is still preferred by many advanced end users 

as its features provide them with more comprehensive control over an operating system's 

functions. 

Good examples of command lines include MS-DOS, Windows command line, Terminal, and the 

Linux command line. 

GUI 

GUI is what most modern computers make use of. This is an interface that makes use of 

graphics, images and other visual clues such as icons. This interface made it possible for a mouse 

to be used with a computer and interaction really became very easy as the user could interact 

with just a click of the mouse rather than having to type every time to give commands to the 

computer. 

Modern operating systems use a graphical user interface, or GUI (pronounced gooey). A GUI 

lets you use your mouse to click icons, buttons, and menus, and everything is clearly displayed 

on the screen using a combination of graphics and text. 

Icons 

•Small pictures that represent commands, files, or windows. 

 

Difference between CUI and GUI 

• CUI and GUI are user interface used in connection with computers 
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• CUI is the precursor of GUI and stands for character user interface where user has to type on 

keyboard to proceed. On the other hand GUI stands for Graphical User Interface which makes it 

possible to use a mouse instead of keyboard 

• GUI is much easier to navigate than CUI 

• There is only text in case of CUI whereas there are graphics and other visual clues in case of 

GUI 

• Most modern computers use GUI and not CUI 

• DOS is an example of CUI whereas Windows is an example of GUI. 

 

TYPES OF OPERATING SYSTEM 

The categories are: 

 Real-time operating system (RTOS) - Real-time operating systems are used to control 

machinery, scientific instruments and industrial systems. An RTOS typically has very little 

user-interface capability, and no end-user utilities, since the system will be a "sealed box" 

when delivered for use. A very important part of an RTOS is managing the resources of the 

computer so that a particular operation executes in precisely the same amount of time, every 

time it occurs. In a complex machine, having a part move more quickly just because system 

resources are available may be just as catastrophic as having it not move at all because the 

system is busy. 

 Single-user, single task - As the name implies, this operating system is designed to manage 

the computer so that one user can effectively do one thing at a time. The Palm OS for Palm 

handheld computers is a good example of a modern single-user, single-task operating system. 

 Single-user, multi-tasking - This is the type of operating system most people use on their 

desktop and laptop computers today. Microsoft's Windows and Apple's MacOS platforms are 

both examples of operating systems that will let a single user have several programs in 

operation at the same time. For example, it's entirely possible for a Windows user to be 

writing a note in a word processor while downloading a file from the Internet while printing 

the text of an e-mail message. 

 Multi-user - A multi-user operating system allows many different users to take advantage of 

the computer's resources simultaneously. The operating system must make sure that the 

requirements of the various users are balanced, and that each of the programs they are using 

has sufficient and separate resources so that a problem with one user doesn't affect the entire 

community of users. Unix, VMS and mainframe operating systems, such as MVS, are 

examples of multi-user operating systems. 

 Batch Processing- Batch processing is a technique in which an Operating System collects 

the programs and data together in a batch before processing starts. An operating system does 

the following activities related to batch processing:  The OS defines a job which has 

predefined sequence of commands, programs and data as a single unit.  The OS keeps a 

number a jobs in memory and executes them without any manual information.  Jobs are 

processed in the order of submission, i.e., first come first served fashion.  When a job 

completes its execution, its memory is released and the output for the job gets copied into an 
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output spool for later printing or processing. Advantages  Batch processing takes much of 

the work of the operator to the computer.  Increased performance as a new job gets started 

as soon as the previous job is finished, without any manual intervention. Disadvantages  

Difficult to debug programs.  A job could enter an infinite loop.  Due to lack of protection 

scheme, one batch job can affect other pending jobs. 

 

 
 

Time-sharing Operating Systems 

Time-sharing is a technique which enables many people, located at various terminals, to use a 

particular computer system at the same time. Time-sharing or multitasking is a logical extension 

of multiprogramming. Processor's time which is shared among multiple users simultaneously is 

termed as time-sharing. 

 

The main difference between Multiprogrammed Batch Systems and Time-Sharing Systems is 

that in case of Multiprogrammed batch systems, the objective is to maximize processor use, 

whereas in Time-Sharing Systems, the objective is to minimize response time. 

 

Multiple jobs are executed by the CPU by switching between them, but the switches occur so 

frequently. Thus, the user can receive an immediate response. For example, in a transaction 

processing, the processor executes each user program in a short burst or quantum of 

computation. That is, if n users are present, then each user can get a time quantum. When the 

user submits the command, the response time is in few seconds at most. 

 

The operating system uses CPU scheduling and multiprogramming to provide each user with a 

small portion of a time. Computer systems that were designed primarily as batch systems have 

been modified to time-sharing systems. 

Advantages of Timesharing operating systems are as follows: 

 Provides the advantage of quick response 

 Avoids duplication of software 

 Reduces CPU idle time 

Multiprogramming 

Sharing the processor, when two or more programs reside in memory at the same time, 

is referred as multiprogramming. Multiprogramming assumes a single shared processor. 

Multiprogramming increases CPU utilization by organizing jobs so that the CPU always has 

one to execute. 



 
B.Com 1st  Year        Subject- Introduction to Computer Fundamental and PC Software 
 

 

45, Anurag Nagar, Behind Press Complex, Indore (M.P.) Ph.: 4262100, www.rccmindore.com 
29 

 

The following figure shows the memory layout for a multiprogramming system. 

 
An OS does the following activities related to multiprogramming. 

 The operating system keeps several jobs in memory at a time. 

 This set of jobs is a subset of the jobs kept in the job pool. 

 

Multiprogramming operating systems monitor the state of all active programs and 

system resources using memory management programs to ensures that the CPU 

is never idle, unless there are no jobs to process. 

Advantage 

 High and efficient CPU utilization. 

 User feels that many programs are allotted CPU almost simultaneously. 

Disadvantages 

 CPU scheduling is required. 

 To accommodate many jobs in memory, memory management is required. 

 

Multitasking 

Multitasking is when multiple jobs are executed by the CPU simultaneously by switching 

between them. Switches occur so frequently that the users may interact with each program 

while it is running. An OS does the following activities related to multitasking: 
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 The user gives instructions to the operating system or to a program directly, and receives an 

immediate response. 

 The OS handles multitasking in the way that it can handle multiple operations / executes 

multiple programs at a time. 

 Multitasking Operating Systems are also known as Time-sharing systems. 

 These Operating Systems were developed to provide interactive use of a computer system at 

a reasonable cost. 

 A time-shared operating system uses the concept of CPU scheduling and multiprogramming 

to provide each user with a small portion of a time-shared CPU. 

 Each user has at least one separate program in memory. 

 A program that is loaded into memory and is executing is commonly referred to as a process. 

 When a process executes, it typically executes for only a very short time before it either 

finishes or needs to perform I/O. 

 Since interactive I/O typically runs at slower speeds, it may take a long time to complete. 

During this time, a CPU can be utilized by another process. 

 The operating system allows the users to share the computer simultaneously. Since each 

action or command in a time-shared system tends to be short, only a little CPU time is 

needed for each user. 

 As the system switches CPU rapidly from one user/program to the next, each user is given 

the impression that he/she has his/her own CPU, whereas actually one CPU is being shared 

among many users. 

Real-Time Operating System 

A real-time system is defined as a data processing system in which the time interval required to 

process and respond to inputs is so small that it controls the environment. The time taken by the 

system to respond to an input and display of required updated information is termed as the response 

time. So in this method, the response time is very less as compared to online processing. 

 

Real-time systems are used when there are rigid time requirements on the operation of a processor or 

the flow of data and real-time systems can be used as a control device in a dedicated application. A 

real-time operating system must have well-defined, fixed time constraints, otherwise the system will 

fail. For example, Scientific experiments, medical imaging systems, industrial control systems, 

weapon systems, robots, air traffic control systems, etc. 

There are two types of real-time operating systems. 
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Hard real-time systems 

Hard real-time systems guarantee that critical tasks complete on time. In hard real-time 

systems, secondary storage is limited or missing and the data is stored in ROM. In these 

systems, virtual memory is almost never found. 

Soft real-time systems 

Soft real-time systems are less restrictive. A critical real-time task gets priority over other 

tasks and retains the priority until it completes. Soft real-time systems have limited utility 

than hard real-time systems. For example, multimedia, virtual reality, Advanced Scientific 

Projects like undersea exploration and planetary rovers, etc. 

Distributed processing is a phrase used to refer to a variety of computer systems that use more than 

one computer (or processor) to run an application. This includes parallel processing in which a 

single computer uses more than one CPU to execute programs 

Distributed computing is a technique of distributing the information over number of devices. 

Devices may be computers or data terminals. Devices are interconnected with communication 

facilities. 

Microsoft Windows 

Microsoft created the Windows operating system in the mid-1980s. Over the years, there have been 

many different versions of Windows, but the most recent ones are Windows 10 (released in 2015), 

Windows 8 (2012), Windows 7 (2009), and Windows Vista (2007). Windows comes pre-loaded on 

most new PCs, which helps to make it the most popular operating system in the world. 

Mac OS X 

Mac OS is a line of operating systems created by Apple. It comes preloaded on all new Macintosh 

computers, or Macs. All of the recent versions are known as OS X (pronounced O-S Ten), and the 

specific versions include El Capitan (released in 2015), Yosemite (2014), Mavericks (2013), 

Mountain Lion (2012), and Lion (2011). 

Linux 

Linux  is a family of open-source operating systems, which means they can be modified and 

distributed by anyone around the world. This is different from proprietary software like Windows, 

which can only be modified by the company that owns it. The advantages of Linux are that it is free, 

and there are many different distributions—or versions—you can choose from. 

Different distributions of Linux 

 Ubuntu,  

 Linux Mint 

 Fedora  

Operating systems for mobile devices 
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The operating systems we've been talking about so far were designed to run on desktop and laptop 

computers. Mobile devices such as phones, tablet computers, and MP3 players are different from 

desktop and laptop computers, so they run operating systems that are designed specifically for 

mobile devices. Examples of mobile operating systems include  

 Apple iOS 

 Google Android 

Disk Defragmenter is a utility in Microsoft Windows designed to increase access speed by 

rearranging files stored on a disk to occupy contiguous storage locations, a technique called 

defragmentation. 

Disk Cleaning is a computer maintenance utility included in Microsoft Windows designed to free up 

disk space on a computer's hard drive. The utility first searches and analyzes the hard drive for files 

that are no longer of any use, and then removes the unnecessary files. There are a number of 

different file categories that Disk Cleanup targets when performing the initial disk analysis: 

 Compression of old files 

 Temporary Internet files 

 Temporary Windows files 

 Downloaded program files 

 Recycle Bin 

 Removal of unused applications or optional Windows components 

 Offline web pages (cached) 

MS Windows 

Windows XP is a personal computer operating system produced by Microsoft as part of 

the Windows NT family of operating systems. The operating system was released to manufacturing 

on August 24, 2001, and generally released for retail sale on October 25, 2001. 

 

Windows XP is a graphical user interface (GUI). It has pictures (graphical) that you use (user) to 

communicate (interface) with the computer. This type of system is popular because it's logical, fun, 

and easy to use. 

This operating system has multi-tasking capabilities, meaning it can run several applications at the 

same time. Multi-tasking allows you to view this lesson on the Internet at the same time you practice 

using other applications with Windows XP. 

History of Windows: 

 

Versions Year 

Windows 10 Nov.1983 

Windows 1.0 Nov.1985 

Windows 2.0 09 Dec.1987 

Windows 3.0 22 May.1990 

Windows 95 August 1995 
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Windows 98 June 1998 

Windows 2000 Feb.2000 

Windows XP 25 Oct. 2001 

Windows  Vista 2007 

Windows 7 22 July 2009 

Windows 8 26 Oct. 2012 

 

The New and updated features in the new program are: 

 Windows XP is faster, smarter, safer 

 Windows XP is easier to learn and use 

 Windows XP offers better help for 

every task 

 Playing music, video and CDs 

 Offers wizard 

 User interface 

 Infrastructure 

 Networking and internet functionality 

 

Windows XP editions 

 Home and Professional 

 Starter Edition 

 Media Center Edition 

 Tablet PC Edition 

 Subscription and pre-paid editions 

 64-bit editions 

 Editions for embedded systems 

 

Windows XP is an operating system 

 Windows XP is a collection of programs, which enables the entire pc to work. Among Windows‘ 

most important tasks are: 

 Assist in starting the pc. 

 Control and handling of all hardware, including RAM, I/O, cards and controllers. 

 Read-in of a graphics user interface with windows, menu bars etc. 

 Forms a platform for the user programs (applications) like Word, Internet Explorer, and 

Photoshop etc. 

 Handling of user data in files. 

 

Beyond the pure operating system tasks Windows XP includes a large collection of smaller and 

larger tools. Among others Windows XP comes with Internet Explorer and the multimedia player 

Windows Media Player, which are independent user programs. 
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Windows XP is both an operating system and a program package. 

 

Desktop 

Desktops in a Windows is utility that allows users to manage applications on up to four virtual 

desktops, all accessible using the tray icon interface. 4. When referring to an operating system or 

GUI, the Desktop is a system of organization of icons on a screen. The Microsoft Windows Desktop 

was first introduced with Microsoft Windows 95 and has been included with every version of 

Windows since then. 

 
The desktop contains: 

 Start button: This is one of the most important tools you will use while working with 

Windows XP. The Start button allows you to open menus and start applications. 

 Taskbar: This is primarily used to switch between open windows and applications. Learn 

more about using the taskbar in a later lesson. 

 Icons (or graphical pictures): This represents applications, files, and other parts of the 

operating system. By default, Windows XP provides you with one desktop icon, the Recycle 

Bin.  

 Windows Notification Area 
 Time and Date: The date and time is also shown on the Desktop, in the notification area on 

the taskbar. If the date and time is incorrect, you can change the date and time right from the 

Desktop. 

 

Exploring Windows Explorer 
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Windows Explorer is a file management tool that lets you create, rename, and delete folders. It also 

allows you to copy, print, move, delete, rename, and manage files. 

To open Windows Explorer: 

1. Open My Documents. 

2. Click the Folders button on the Navigation toolbar. 

3. A list of folders opens in the left pane. 

To explore Windows Explorer: 

1. With Windows Explorer open, scroll until you see the Control Panel icon in the left pane. 

2. Click the Control Panel icon. The contents (of the Control Panel folder) display in the right 

pane. 

3. Practice viewing other folders in the list. 

4. To close Windows Explorer, click the small black X in the upper right of the list OR click 

the Folder button. 

 

The Taskbar 

The taskbar is the small blue bar you see at the bottom of your desktop. It contains the Start 

menu and the Quick Launch bar, which contains icons for Internet Explorer, Windows Media 

Player, and Show Desktop. Click an icon to open a program. Click Show Desktop to quickly view 

your desktop without closing any programs or windows. 

 
 

The box on the right is called the Notification Area. Microsoft also uses the Notification Area to 

remind you when software updates are available for download. 

 
 

When you open or minimize a window or program, a rectangular button appears on the taskbar 

that shows the name of the application.  

 

The Start menu 

When you click the Start button, the Start menu appears. The Start menu is your path to the 

applications on your computer. It contains two columns. The left side of the Start menu lists 

programs, while the right side allows access to common Windows folders (My Documents, for 

example). It also provides access to Help and Support, Search, and Run. If you select All 

Programs, a pop-up menu appears. Pop-up menus like this are called cascading menus. If a 

cascading menu is available, a small black triangle appears next to the name of the application or 

function. 

To explore the Start menu: 

1. Click the Start button. 

2. Move the mouse pointer to each option, and view the various cascading menus. 

3. Click (or roll your mouse pointer over) All Programs. 

4. Move the mouse pointer to the right, and view other cascading menus. 

5. To exit the menus, click outside the menu area or press Esc on your keyboard. 
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The Recycle Bin 

The Recycle Bin is nothing more than a space on the hard disk reserved to store information that is 

deleted so that in the event of deleting a file or folder by mistake it is possible to retrieve it. By 

default the Recycle Bin restores files or folders to the place from where they were deleted. If, for 

example, a file is deleted from D:\my documents, when it is restored it will go to that folder. 

The Recycle Bin will maintain the deleted documents until it is emptied. 

To open the Recycle Bin place the cursor on Desktop and double-click on the Recycle 

Bin icon.  

 

Restoring Files or Folders 

To restore all of the elements from the Recycle Bin click on the green arrow on the left side that 

says restore all items. 

 

If we only want to restore some of the elements: 

1) Select the elements to be restored by clicking on them. If the elements are not in subsequent order, 

use the Ctrl key to select them or the Shift key if they are one below the other. 

2) Once selected, a dialog box will appear on the green arrow on the left that will say Restore this 

item or Restore the selected items. 

The selected files will return to where they were located before deletion. 

 

Deleting Files or Folders from the Recycle Bin 

Before deleting any element from the Recycle Bin you need to realize that once it is deleted it cannot 

be retrieved or restored. 

 If you want to delete any file or folder from the Recycle Bin follow these steps: 
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1) Select the Elements to be deleted. 

2) Click on ; this will delete the selected elements. You can also do this by pressing 

the Delete button. 

The selected files will disappear and cannot be restored. 

 

My Computer 

It is another tool you can use to manage files and folders. With this tool, you can create, rename 

and move folders and copy, print, move, delete and rename files. It also allows you to gain access 

to other 

system tools. 

To open My Computer: 

1. Double-click the My Computer icon on the desktop. 

2. My Computer opens. 

 

My Network Places overview 

My Network Places displays shortcuts to shared computers, printers, and other resources on the 

network. The shortcuts are created automatically in My Network Places whenever you open a shared 

network resource, such as a printer or shared folder. 

 

Open My Network Places 

 To open My Network Places, click Start, and then click My Computer. Under Other Places, 

click My Network Places.  

 The View workgroup computers task is displayed in My Network Places when your 

computer is in a workgroup and not in a domain. Double-click this icon to narrow your 

search to only those computers, printers, and resources that share a workgroup with your 

computer.  

 If your computer is connected to a workgroup that has less than 32 computers, Windows will 

automatically create shortcuts in My Network Places to the shared resources in your 

workgroup.  

 To add a shortcut in My Network Places to a folder on a Web server, the Web server must 

support network places.. 

 

My Documents 

The My Documents folder is your own personal folder in which you can store your documents, 

graphics, and other personal files. You can change the target if you want My Documents to point to a 

different folder location.  

 Change the Default Location of the My Documents Folder 

 To change the default location of the My Documents folder, follow these steps:  

 Click Start, and then point to My Documents.  

 Right-click My Documents and then click Properties. Click the Target tab.  

 

User Accounts 

To get at the settings for the User Accounts, click Start and then Control Panel. From the Control 

Panel, double click User Accounts.  

 We can create a new user account. 

 We can make the account as password protected. 

 Through admin we can even change the password. 
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Windows XP Accessories Applications:  

 Calculator,  

 Notepad,  

 WordPad,  

 Paint  
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1. Using Windows XP Calculator 

Like a calculator you keep in a desk drawer, the 

Windows Calculator is small but saves you time by 

performing all the calculations common to a standard 

calculator. 

The Standard Windows Calculator works so much like a 

pocket calculator that you need little help getting started. 

To display the Calculator, open the Start menu and 

choose Programs, Accessories, Calculator. The 

Calculator opens in the same view (Standard or 

Scientific) in which it was displayed the last time it was 

used. 

 To close the Calculator, click the Close button in the 

title bar. If you use the Calculator frequently, however, 

don't close it; click the Minimize button to minimize the 

Calculator to a button on the taskbar. 

The Calculator has only three menus: Edit, View, and Help. The Edit menu contains two simple 

commands for copying and pasting; the View menu switches between the Standard and Scientific 

views; and the Help menu is the same as in all Windows accessories. 

 

 

2.   Using Windows XP Notepad  
Notepad is a miniature text after the 

calculations are performed. To enter 

numbers from the editor.  Just as you use 

a notepad on your desk, you can use 

Notepad to take notes onscreen while 

working in other Windows applications. 

 

Because Notepad stores files in text 

format, almost all word processing 

applications can retrieve Notepad's files. 

However, if you want the capability of 

formatting your documents, you'll need a true word processor. 

 

Starting Notepad 

To start Notepad, open the Start menu and choose Programs, Accessories, Notepad. Notepad starts 

up and displays a blank document in the Notepad window . 

 

Working with Documents in Notepad 

You can move the insertion point by using either the mouse or the keyboard. You select and edit text 

in Notepad the same way you select and edit text in WordPad. 

Limited formatting is available from the File, Page Setup command. You can change margins and 

add a header or footer, but you cannot format characters or paragraphs in any way. You also can use 

the Tab, Spacebar, and Backspace keys to align text. Tab stops are preset at every eight characters. 
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With the commands on Notepad's Edit menu, you can cut, copy, and move text from one place in a 

file to another. Text that you cut or copy is stored in the Clipboard. When you paste text, the contents 

of the Clipboard are copied from the Clipboard to the document at the location of the insertion point. 

 

  

 3. Using Windows XP WordPad 

 

Word Pad is the word processor that comes 

with Windows XP that can perform most 

basic word processing tasks. Although it is 

not nearly as powerful and versatile as a 

full-featured word processing application 

(such as Microsoft Word XP), it is much 

more powerful than Notepad, the text 

editor that comes with Windows XP. 

 

Creating a New Document in WordPad 

WordPad is located in the Accessories 

submenu of the Start menu. To start 

WordPad, open the Start menu and choose Programs, Accessories, WordPad. The WordPad window 

appears. When you first open WordPad, you are presented with a blank document. 

  

 

4.Using Windows XP Paint 

Paint is n easy-to-learn graphics application 

that you can use to create and modify graphics 

images. 

 

Steps for starting Windows Paint 

To start Paint, click Start, Programs, 

Accessories, Paint. Paint starts up and opens a 

new, empty Paint file 

 

5.Using Windows XP Entertainment 

 Windows XP includes entertainment 

programs for playing CDs, viewing 

multimedia files, and recording and playing 

back sounds.  

It is capable of performing many tasks like: 

1. Playing Games 

2. Changing the Volume 

3. Playing a Sound with Sound Recorder 

4. Playing an Audio CD 

5. Working with Media Player Controls 

6. Changing the Visualizations 

7. Copying CD Tracks 

8. Using the Media Library 
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9. Creating a Playlist 

10. Tuning into the Radio 

11. Changing the Skin for Windows Media Player 

12. Playing a Video Clip 

13. Importing a Movie with Windows Movie Maker 

 

6. Using Windows XP Address Book 

 
 

The Address Book provides a convenient place to store contact information for easy retrieval from 

programs such as Outlook, Outlook Express, Internet Explorer, NetMeeting, and Microsoft Phone 

System. You can search for people and businesses, create groups of contacts for mailing lists, and 

send and receive electronic business cards. 

 Start Click All Programs, Accessories, Address Book 

Address Book Window will appear. 

 

Functions of address book as follows: 

 Create a new entry 

 Delete the existing entry 

 Edit the existing entry and etc 

 

Changing Mouse Pointer 

1. Open Mouse Properties by clicking the Start button The Start button, and then clicking 

Control Panel. In the search box, type mouse, and then click Mouse. 

2. Click the Pointers tab, and then do one of the following:        

 To give all of your pointers a new look, click the Scheme drop-down list, and then click a 

new mouse pointer scheme. 

 To change an individual pointer, under Customize, click the pointer you want to change 

in the list, click Browse, click the pointer you want to use, and then click Open. 

3. Click OK. 
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To change your desktop background 

1. Open Display in Control Panel. 

To open Display, click Start, click Control Panel, click Appearance and Themes, and then 

click Display.  

2. On the Desktop tab, do one or more of the following: 

• 
Click a picture in the Background list. In Position, click Center, Tile, or Stretch. 

• Click Browse to search for a background picture in other folders or on other drives. You can 

use files with the following extensions: .bmp, .gif, .jpg, .dib, .png, .htm. In Position, 

click Center, Tile, or Stretch. 

• 
Select a color from Desktop color. The color fills the space not used by a picture. 

 

Note 

• To open Display, click Start, click Control Panel, click Appearance and Themes, and then 

click Display.  

• You can use a personal picture as a background. All of your personal pictures located in My 

Pictures are listed by name in the Background list. 

• You can save a picture from a Web site as a background. Right-click the picture and then click Set 

as Background. The picture is listed in the Background box as Internet Explorer Background. 

• If you choose an .htm document as your background picture, the Position options are unavailable. 

The .htm document is automatically stretched to fill your background. 

 

Copying and Moving Files and Folders 

Sometimes you will need to move a file from one folder to another, or copy a file from one folder to 

another, leaving the file in the first location and placing a copy of it in the second. You can move or 

copy a file or folder using a variety of methods. If the file or folder and the location where you want 

to move it are visible in a window or on the desktop, you can simply drag the item from one location 

to the other. Moving a file or folder on the same disk relocates it whereas dragging it from one disk 

to another copies it so that it appears in both locations. When the destination folder or drive is not 

visible, you can use the Cut (to move), Copy, and Paste commands on the Edit menu to move or 

copy the items. 

Copy a File or Folder 

1.  Open the drive or folder containing the file or folder you want to copy. 

2.  Select the files or folders you want to copy. 
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Move a File or Folder 

1.  Open the drive or folder containing the file or folder you want to move. 

2.  Select the files or folders you want to move. 
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3. Click the Organize button on the toolbar, and then click Cut. 

4.  Display the destination folder where you want to move the files or folder. 

5.  Click the Organize button on the toolbar, and then click Paste. 

 

Copy or Move a File or Folder Using Drag and Drop 

1.  Open the drive or folder containing the file or folder you want to copy or move. 

2.  Select the files or folders you want to copy or move. 

 

3. In the Navigation pane, point to a folder list to display the expand and collapse arrows. 

4.  Click the arrows to display the destination folder, and then click the destination folder. 

5.  Right-click the selected files or folders, drag to the destination folder, and then click Copy 

Here or Move Here. 

 

 

OLE (Object Linking and Embedding) 

Stands for "Object Linking and Embedding." OLE is a framework developed by Microsoft (way 

back in Windows 3.1) that allows you to take objects from a document in one application and place 

them in another. For example, OLE may allow you to move an image from a photo-editing program 

into a word processing document. 
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The OLE technology was initially created to allow the linking of objects between "compound 

documents," or documents that support multiple types of data. Microsoft has since developed OLE 

into a wider standard, known as the Component Object Model (COM). COM is supported by Mac, 

Unix, and Windows systems, but is primarily used with Microsoft Windows. The COM framework 

is the foundation of ActiveX, which allows developers to create interactive content for the Web 

OLE (Object Linking and Embedding) is Microsoft's framework for a compound document 

technology. Briefly, a compound document is something like a display desktop that can contain 

visual and information objects of all kinds: text, calendars, animations, sound, motion video, 3-D, 

continually updated news, controls, and so forth. Each desktop object is an independent program 

entity that can interact with a user and also communicate with other objects on the desktop. Part of 

Microsoft's ActiveX technologies, OLE takes advantage and is part of a larger, more general 

concept, the Component Object Model (COM) and its distributed version, DCOM. An OLE object is 

necessarily also a component (or COM object). OLE contains about 660 new function calls or 

individual program interfaces in addition to those already in Win32. 
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UNIT 3 

Microsoft Word 

Word processor 

A word processor is an electronic device or computer application software that performs word 

processing: the composition, editing, formatting and sometimes printing of any sort of written 

material. Word processing can also refer to advanced shorthand techniques, sometimes used in 

specialized contexts with a specially modified typewriter. 

The word processor emerged as a stand-alone office machine in the 1970s and 1980s, combining the 

keyboard text-entry and printing functions of an electric typewriter with a dedicated computer 

processor for the editing of text. 

 

Characteristics 

Word processing typically implies the presence of text manipulation functions that extend beyond a 

basic ability to enter and change text, such as automatic generation of: 

 batch mailings using form letter template and an address database (also called mail merging); 

 indices of keywords and their page numbers; 

 tables of contents with section titles and their page numbers; 

 tables of figures with caption titles and their page numbers; 

 cross-referencing with section or page numbers; 

 footnote numbering; 

 New versions of a document using variables (e.g. model numbers, product names, etc.) 

 

Examples of different word processing software are: 

 WordPerfect 

 Microsoft Word 

 WordMark 

 Lotus WordPro 

 Procedure Write 
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Types of word processor:- 

 

 Dedicated word processor 

 Standard word processor software packages 

 Word processing packages on minicomputer 

 

Microsoft office Word:- 

Microsoft Office Button :- After clicking you get the Menu to create, open, save and perform 

other operations 
The Ribbon:- The Ribbon is the panel at the top portion of the document. It has seven tabs: Home, 

Insert, Page Layout, References, Mailings, Review, and View that contain many new and existing 

features of Word.  

Each of the tabs contains the following tools: 

 Home: Clipboard, Fonts, Paragraph, Styles, and Editing.  

  Insert: Pages, Tables, Illustrations, Links, Header & Footer, Text, and Symbols 

  Page Layout: Themes, Page Setup, Page Background, Paragraph, Arrange 

  References: Table of Contents, Footnote, Citation & Bibliography, Captions, Index, and 

Table of Authorities 

  Mailings: Create, Start Mail Merge, Write & Insert Fields, Preview Results, Finish 

 Review: Proofing, Comments, Tracking, Changes, Compare, Protect 

  View: Document Views, Show/Hide, Zoom, Window, Macros 

 

Ruler: - Can use to change the format of your document quickly. 

Text area: - The area for writing the document is called Text Area. 

Status Bar: - appears at the very bottom of your window and provides the information about the 

current page and number of words in your document. 

Scroll Bar: - you have two types of scroll bar i.e. horizontal and vertical scroll bar to move the 

document. 
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Formatting Features of Ms Word:- 

 

 
 

 

The commonly used are as follows:- 

 Bold and italic 

 Underlined 

 Font style 

 Font size 

 Text color 

 Indent 

 Alignment 

 

To format font size: 

 Select the text you wish to modify. 
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 Left-click the drop-down arrow next to the font size box on the Home tab. The font size 

drop-down menu appears. 

 Move your cursor over the various font sizes. A live preview of the font size will appear in 

the document. 

 Left-click the font size you wish to use. The font size will change in the document. 

 

To format font style: 

 Select the text you wish to modify. 

 Left-click the drop-down arrow next to the font style box on the Home tab. The font style 

drop-down menu appears. 

 Move your cursor over the various font styles. A live preview of the font will appear in the 

document. 

 Left-click the font style you wish to use. The font style will change in the document. 

 

To format font color: 

 Select the text you wish to modify. 

 Left-click the drop-down arrow next to the font color box on the Home tab. The font color 

menu appears. 

 Move your cursor over the various font colors. A live preview of the color will appear in the 

document. 

 Left-click the font color you wish to use. The font color will change in the document. 

 

 

To use the bold, italic, and underline commands: 

 Select the text you wish to modify. 

 Click the bold, italic, or underline command in the Font group on the Home tab. 

 

To change the text case: 

 Select the text you wish to modify. 

 Click the Change Case command in the Font group on the Home tab. 

 Select one of the case options from the list. 

 

To change text alignment: 

 Select the text you wish to modify. 

 Select one of the four alignment options from the Paragraph group on the Home tab. 

o Align Text Left: Aligns all of the selected text to the left margin. 

o Center: Aligns text an equal distance from the left and right margins. 

o Align Text Right: Aligns all of the selected text to the right margin. 

o Justify: Justified text is equal on both sides and lines up equally to the right and left 

margins. Traditionally, many books, newsletters, and newspapers use full 

justification. 

 

Working with text:- 

To insert text: 

 Move your mouse to the location you wish text to appear in the document. 

 Left-click the mouse. The insertion point appears. 

 Type the text you wish to appear. 



 
B.Com 1st  Year        Subject- Introduction to Computer Fundamental and PC Software 
 

 

45, Anurag Nagar, Behind Press Complex, Indore (M.P.) Ph.: 4262100, www.rccmindore.com 
50 

 

 

To delete text: 

 Place your cursor next to the text you wish to delete. 

 Press the Backspace key on your keyboard to delete text to the left of the cursor. 

 Press the Delete key on your keyboard to delete text to the right of the cursor. 

 

To select text: 

 Place the insertion point next to the text you wish to select. 

 Left-click your mouse and while holding it down, drag your mouse over the text to select it. 

 Release the mouse button. You have selected the text. A highlighted box will appear over the 

selected text. 

When you select text or images in Word, a hover toolbar with formatting options appears. This 

makes formatting commands easily accessible, which can save you time. 

 

To copy and paste text: 

 Select the text you wish to copy. 

 Click the Copy command on the Home tab. 

 Place your insertion point where you wish the text to appear. 

 Click the Paste command on the Home tab. The text will appear. 

 
To drag and drop text: 

 Select the text you wish to copy. 

 Left-click your mouse, and drag the text to the location you wish it to appear. The cursor will 

have a text box underneath it to indicate that you are moving text. 

 
 

 

Word Art 

Word Art are styles that can be applied to text to create a visual effect. To apply Word Art:- 

 Select text 

 Click insert tab 

 Click word Art 

 Choose the Word Art 

 Select the Word Art 
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 Click the format tab from the drawing 

tools 

 Click Word Art button  

 

Working with Header, Footers and Footnotes 

The header is a section of the document that appears in the top margin, while the footer is a section 

of the document that appears in the bottom margin. Headers and footers generally contain 

information such as page number, date, and document name.  

Header: - Header consists of text and graphics appears at the top of every page of a document. 

Footers: - Footers appears at the bottom of every page in the same document. 

For e.g.: - you can date page number, the time and date, a company logo, the document title. 

 

Steps to insert header and footers:- 

 There are different options to inset header and footer they are as follows:- 

 Insert the same header or footer on each page 

 Insert predefined header and footer 

 Insert custom header and footer 

 Make the first page header or footer different from the rest of the pages. 

 Make the header or footer different for odd and even pages. 

 Make the header or footer different in each section or chapter 

 Use documents section breaks to vary the header or footer. 

 Use the same header or footer across section boundaries 

 Change the contents of a header or footer 

 Insert a page number 

 

To insert a header or footer: 

 Select the Insert tab. 

 Click either the Header or Footer command. A menu appears with a list of built-in 

options you can use. 

 Left-click one of the built-in options, and it will appear in the document. 

 

OR 

 Left-click Blank to select it. 
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 The Design tab with Header and Footer tools is active. 

 
 

 Type information into the header or footer. 

 
 

To insert the date or time into a header or footer: 

 With the header or footer section active, click the Date & Time command. 
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 Select a date format in the dialog box that appears. 

 Click OK. The date and time now appear in the document. 

 

Other header and footer options 

There are many other header and footer options you can use to design these sections of your 

document. From the Header and Footer Tools Design tab, you can see all of your design options.  

 

Footnotes and end notes:- 

 A footnote or an endnote consists of two linked parts — the note reference mark (note 

reference mark: A number, character, or combination of characters that indicates that 

additional information is contained in a footnote or endnote.) and the corresponding note text. 

 When you add, delete, or move notes that are automatically numbered, Word renumbers the 

footnote and endnote reference marks. 

 

To insert a foot note:- 

 In Print Layout view, click where you want to insert the note reference mark.  

 On the References tab, in the Footnotes group, click Insert Footnote or Insert Endnote.  

 To make changes to the format of footnotes or endnotes, click the Footnotes Dialog Box 

Launcher, and do one of the following:  

 In the Number format box, click the format that you want.  

 To use a custom mark instead of a traditional number format, click Symbol next to Custom 

mark, and then choose a mark from the available symbols.  

 Click Insert.  

 Type the note text.  

 Double-click the footnote or endnote number to return to the reference mark in the document.  

 

Tables:- 

A table is a grid of cells arranged in rows and columns. Tables can be customized and are useful for 

various tasks such as presenting text information and numerical data.  

 

To convert existing text to a table: 

 Select the text you wish to convert. 

 Select the Insert tab. 
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 Click the Table command. 

 Select Convert Text to Table from the menu. A dialog box appears. 

 
 Choose one of the options in the Separate text at: section. This is how Word knows what 

text to put in each column. 

 

 Click OK. The text appears in a table. 

To add a row above an existing row: 

 Place the insertion point in a row below the location where you wish to add a row. 

 Right-click the mouse. A menu appears. 

 Select Insert  Insert Rows Above. 

 

A new row appears above the insertion point. 

You can also add rows below the insertion point. Follow the same steps, but select Insert Rows 

Below from the menu. 

To add a column: 

 Place the insertion point in a column adjacent to the location where you wish the new 

column to appear. 

 Right-click the mouse. A menu appears. 

 Select Insert  Insert Columns to the Left or Insert Columns to the Right. A new 

column appears. 

 

To delete a row or column: 

 Select the row or column. 

 Right-click your mouse, and a menu appears. 

 Select Delete Columns or Delete Rows. 

 

To apply a table style: 

 Select the table. A Table Tools Design tab now appears on the Ribbon. 

 Select the Design tab to access all of the Table Styles and Options. 

 Click through the various styles in the Table Styles section. 

 Left-click a style to select it. The table style will appear in the document. 

 

You can modify which table styles are displayed. In the Table Styles Options, you can select and 

deselect various table options 
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To insert a blank table: 

 Place your insertion point in the document where you want the table to appear. 

 Select the Insert tab. 

 Click the Table command. 

 Drag your mouse over the diagram squares to select the number of columns and rows in the 

table. 

 Left-click your mouse, and the table appears in the document. 

 Enter text into the table. 

Modify a table using the layout tab 

When you select a table in Word 2007, Design and Layout tabs appear under Table Tools on the 

Ribbon. Using commands on the Layout tab, you can make a variety of modifications to the table, 

including: 

 Adding and deleting columns 

 Adding and deleting rows 

 Changing the cell size 

 Aligning cell text 

 Changing text direction 

 Merging and splitting cells 

 

 
 

Other Table handling Features: 

 Insert tables by insert table. 

 Drawing a table 

 Adding text into the table 

 Formatting text within a table 

 Selecting a part of table 

 Align table 

 Inserting rows, columns, and cells 

 

To insert a picture: 

 Place your insertion point where you want the image to appear. 

 Select the Insert tab. 

 Click the Picture command in the Illustrations group. The Insert Picture dialog box appears. 

 



 
B.Com 1st  Year        Subject- Introduction to Computer Fundamental and PC Software 
 

 

45, Anurag Nagar, Behind Press Complex, Indore (M.P.) Ph.: 4262100, www.rccmindore.com 
56 

 

 

 

 Select the image file on your computer. 

 Click Insert, and it will appear in your document. 

Left-click a corner sizing handle, and while holding down the mouse button resize the image. The 

image retains its proportions. 

 

To wrap text around an image: 

 Select the image. 

 Select the Picture Tools Format tab. 

 Click the Text Wrapping command in the Arrange group. 

 

 Left-click a menu option to select it. In this example, we selected Tight. 

 Move the image around to see how the text wraps for each setting. 

 The Position button has predefined text wrapping settings. The Position button is to the left of 

the Text Wrapping button. 

 Click the Position button, and a drop-down list of text wrapping options will appear. Hover 

over an option to see what it does. 

If you can‘t get your text to wrap the way you wish, click the Text Wrapping command, and 

select More Layout Options from the menu. You can make more precise changes in the Advanced 

Layout dialog box that appears. 

 

To crop an image: 

 Select the image. 

 Select the Format tab. 

 Click the Crop command. The black cropping handles appear. 

 Left-click and move a handle to crop an image. 

 Click the Crop command to deselect the crop tool. 

 Corner handles will crop the image proportionally. 

 

To compress a picture: 

 Select the picture. 

 Select the Format tab. 

 Click the Compress Pictures command in the Adjust group. A dialog box appears. 

 Click the Options button to access the Compression Setting dialog box. 

 Choose the target output. 

 Change any of the default picture settings you wish. 

 Click OK in the Compression Settings dialog box. 

 Click OK in the Compress Pictures dialog box. 

You need to monitor the file size of your images and documents that include images, 

especially if you send them via email. Cropping and resizing an image doesn‘t decrease 

the image file size, but compression does. 

 

Other picture tools 

There are many other things you can do to modify a picture. From the Format tab, some of the 

other useful commands include: 

 Change Picture command: Selects a new picture from your computer. 
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 Reset Picture command: Reverts to original image. 

 Brightness command: Adjusts the brightness of the image. 

 Color command: Adjusts the contrast of the image from light to dark. 

 Recolor command: Modifies the color in a variety of ways, including black and 

white, sepia, pink, and purple. 

 

To change the shape of a picture: 

 Select the picture. 

 Select the Format tab. 

 Click the Picture Shape icon. A menu appears. 

 Left-click a shape to select it. 

 

To apply a picture style: 

 Select the picture. 

 Select the Format tab. 

 Click the More drop-down arrow to display all of the picture styles. 

 Hover over a picture style to display a Live Preview of the style in the document. 

 Left-click a style to select it. 

 

To add a border to a picture manually: 

 Select the picture. 

 Select the Format tab. 

 Left-click the Picture Border commands, and selects a color. 

OR 

 Select Weight from the menu and choose a line weight. 

 

Adding clip art: 

 Select the Insert tab. 

 Click the Clip Art command in the Illustrations group. 

 
 The Clip Art options appear in the task pane on the right. 

 Enter keywords in the Search for: fields that are related to the image you wish to insert. 

 Click the drop-down arrow next to the Search in: field. 

 Select Everywhere to ensure that Word searches your computer and its online resources for 

an image that meets your criteria. 
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 Click the drop-down arrow in the Results should be: field. 

 Deselect any types of images you do not wish to see. 

 
 Click Go. 

To insert Clip Art: 

 Review the results from a Clip Art search. 

 Place your insertion point in the document where you wish to insert the Clip Art. 

 Left-click an image in the task pane. It will appear in the document. 

OR 

 Left-click the arrow next to an image in the task pane. 

 Select Insert, Copy, or any of the other options on the list. 
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Adding Shapes: 

 Click insert tab 

 Click the shape button 

 Choose the shape 

 Click on the document 

 Drag the cursor to expand the shape. 

 

Adding SmartArt: 

 Click insert tab 

 Click SmartArt button 

 Choose the Smartart 

 Click the SmartArt. 

 Drag it to the desired location in 

document 
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Using a Template 

A template is a predesigned document you can use to create new documents with the same 

formatting. With a template, many of the big document design decisions such as margin size, font 

style and size, and spacing are predetermined. 

To insert a template: 

 Click the Microsoft Office Button. 

 Select New. The New Document dialog box appears. 

 Select Installed Templates to choose a template on your computer. 

 
 Review the available templates. 

 Left-click a template to select it. 

 Click Create, and the template opens in a new window. 

 

Macros 

Macros are advanced features that can speed up editing or formatting you may perform often in a 

Word document. They record sequences of menu selections that you choose so that a series of 

actions can be completed in one step. 

Recording a Macro 

To record a Macro: 

 Click the View Tab on the Ribbon 

 Click Macros 

 Click Record Macro 

 

 Enter a name (without spaces) 

 Click whether you want it assigned to a button (on the Quick Access Toolbar) or 

the keyboard (a sequence of keys) 

 To assign the macro a button on the Quick Access Toolbar: 

 Click Button 
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 Under the Customize Quick Access Toolbar, select the document for which you 

want the Macro available 

 Under Choose Commands:  Click the Macro that you are recording 

 Click Add 

 Click OK to begin Recording the Macro 

 Perform the actions you want recorded in the Macro 

 Click on Macros 

 Click on Stop Recording Macros 

 To assign a macro button to a keyboard shortcut: 

 Click Keyboard 

 In the Press New Shortcut Key box, type the key sequence that you want and 

click Assign 

 Click Close to begin recording the Macro 

 Perform the actions you want recorded in the Macro 

 Click on Macros 

 Click on Stop Recording Macros 

 

Running a Macro 

running a macro depends on whether it‘s been added to the Quick Access Toolbar or if it‘s been 

given a Keyboard Shortcut. 

 To run a Macro from the Quick Access Toolbar, simply click the Macro Icon 

 To run a Macro from the Keyboard shortcut, simply press the keys that you have 

programmed to run the Macro. 

 

Mail Merge 

Mail Merge is used to create and print letters and other documents, such as a form letter that is 

sent to many customers. Each letter has the same kind of information, yet the content is unique. 

For example, in letters to your customers, each letter can be personalized to address each 

customer by name. The unique information in each letter comes from entries in a data source.  

The mail merge process entails the following overall steps: 

 Set up the main document: - The main document contains the text and graphics that are 

the same for each version of the merged document — for example, the return address or 

salutation in a form letter.  

 Connect the document to a data source:-A data source is a file that contains the 

information to be merged into a document. For example, the names and addresses of the 

recipients of a letter.  

 Refine the list of recipients or items. Microsoft Office Word generates a copy of the main 

document for each item, or record, in your data file. If your data file is a mailing list, 

these items are probably recipients of your mailing. If you want to generate copies for 

only certain items in your data file, you can choose which items (records) to include.  

 Add placeholders, called mail merge fields, to the document. When you perform the mail 

merge, the mail merge fields are filled with information from your data file.  

 Preview and complete the merge. You can preview each copy of the document before you 

print the whole set.  

 You use commands on the Mailings tab to perform a mail merge. 
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 You can also perform a mail merge by using the Mail Merge task pane, which leads you step by 

step through the process. To use the task pane, in the Start Mail Merge group on the Mailings tab, 

click Start Mail Merge, and then click Step by Step Mail Merge Wizard. 

Steps 1-3 

 Choose the type of document you wish to create. In this example, select Letters. 

 Click Next: Starting document to move to Step 2. 

 Select Use the current document. 

 Click Next: Select recipients to move to Step 3. 

 Select the Type a new list button. 

 Click Create to create a data source. The New Address List dialog box appears. 

o Click Customize in the dialog box. The Customize Address List dialog box appears. 

o Select any field you do not need and click Delete. 

o Click yes to confirm that you wish to delete the field. 

o Continue to delete any unnecessary fields. 

o Click Add. The Add Field dialog box appears. 

o Enter the new field name. 

o Click OK. 

o Continue to add any fields necessary. 

o Click OK to close the Customize Address List dialog box. 

To Customize the New Address List: 
 Enter the necessary data in the New Address List dialog box. 

 Click New Entry to enter another record. 

 Click Close when you have entered all your data records. 

 Enter the file name you wish to save the data list as. 

 Choose the location you wish to save the file. 

 Click Save. The Mail Merge Recipients dialog box appears and displays all the data records 

in the list. 

 Confirm the data list is correct and click OK. 

 Click Next: Write your letter to move to Step 4. 

 

Steps 4-6 

 Write a letter in the current Word document, or use an open, existing document. 

To Insert Recipient Data from the List: 

o Place the insertion point in the document where you wish the information to appear. 

o Select Address block, Greeting line, or Electronic postage from the task pane. A dialog 

box with options will appear based on your selection. 

OR 

o Select More Items. The Insert Merge Field dialog box will appear. 

o Select the field you would like to insert in the document. 

o Click Insert. Notice that a placeholder appears where information from the data record 

will eventually appear. 

o Repeat these steps each time you need to enter information from your data record. 

 Click Next: Preview your letters in the task pane once you have completed your letter. 
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 Preview the letters to make sure the information from the data record appears correctly in 

the letter. 

 Click Next: Complete the merge. 

 Click Print to print the letters. 

 Click All. 

 Click OK in the Merge to Printer dialog box. 

 Click OK to send the letters to the printer. 

 

The Mail Merge wizard allows you to complete the mail merge process in a variety of ways.  

 

MS Excel 2007 

 

Excel Basics:- 

Excel 2007 is the spreadsheet software in the Microsoft 2007 Office Suite. It allows you to store, 

organize, and analyze numerical and text data. 

 

Ribbons 

Located where taskbars used to be, ribbons graphically display the changing features as you click 

on the menu-bar tabs. It may be take you time to adjust to the new locations of familiar options, but 

ribbons may expose you to new commands and tools.  

 

 

The Ribbon provides you the below tabs:- 

 Home:- Change the Font, Paragraph and Heading styles and view the clipboard and editing 

options 

 Insert:- Insert pages, tables, illustrations, links, headers, footers, text and symbols 

 Page Layout:- Alter page setup, background, themes, paragraph properties, and arrangement 

of document 

 Formulas:- Insert functions and create custom formulas. 

 Data:- Get external data, sort, filter, and outline existing. 

 Review:- Use proofing techniques, insert comments, track changes, compare and protect 

documents 

 View:- Change document and window layout, show/hide thumbnails, and view/record 

macros 

 Add-Ins:- Customize toolbars 

 

Above the Ribbon in the upper-left corner is the Microsoft Office Button. From here, you can 

access important options such as New, Save, Save As, and Print. By default, the Quick Access 

Toolbar is pinned next to the Microsoft Office Button and includes commands such as Undo and 

Redo. 

 

At the bottom-left area of the spreadsheet, you will find worksheet tabs. By default, three worksheet 

tabs appear each time you create a new workbook. On the bottom-right area of the spreadsheet you 

will find page view commands, the zoom tool, and the horizontal scrolling bar. 
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To change page views: 

 Locate the Page View options in the bottom-right corner. The Page View options are 

Normal, Page Layout, and Page Break. 

 Left-click an option to select it. 

 

“The default is Normal View.” 

To add commands to the Quick Access Toolbar: 

 Click the arrow to the right of the Quick Access Toolbar. 

 Select the command you wish to add from the drop-down list. It will appear in the Quick 

Access Toolbar. 

 

Spreadsheets and Workbooks 

A spreadsheet is a grid of data divided into numbered rows and lettered columns. Each block in this 

grid is called a cell, and it can hold an individual piece of text or data. In Excel, a file/document is 

considered a spreadsheet, although it is commonly referred to as a workbook. 

 

Worksheets 

The worksheet is a page of data in your spreadsheet (or workbook) that is organized by the labeled 

tabs displayed at the bottom of the Excel window. 

• Your spreadsheet can contain as many worksheets as you want. By default, however, all newly 

opened Excel spreadsheets have three worksheets. 

• To view the contents of a worksheet, click on its tab. 

 

Create or delete an Excel table in a worksheet 

A worksheet consists of cells that are organized into columns and rows; a worksheet is always 

stored in a workbook. 

The primary document that you use in Excel is to store and work with data. It is also called a 

spreadsheet.  

You can manage and analyze the data in that table independently of data outside the table 

 

Create a table 

You can use one of two ways to create a table. You can either insert a table in the default table style 

or you can format your data as a table in a style that you choose. 

 

Insert a table 

1. On a worksheet, select the range of cells that you want to include in the table. The cells can 

be empty or can contain data.  

2. On the Insert tab, in the Tables group, click Table.  

Keyboard shortcut:- You can also press CTRL+L or CTRL+T. 

3. If the selected range contains data that you want to display as table headers, select the My 

table has headers check box.  

 

Format data as a table 
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1. On the worksheet, select a range of empty cells or cells that contain the data that you want 

to quickly format as a table.  

2. On the Home tab, in the Styles group, click Format as Table.  

3. Under Light, Medium, or Dark, click the table style that you want to use.  

 

Convert a table to a range of data 

1. Click anywhere in the table.  

2. On the Design tab, in the Tools group, click Convert to Range.  

 

 

Delete a table 

 On a worksheet, select a table.  

 Press DELETE.  

 

To create a new, blank workbook: 

 Left-click the Microsoft Office Button. 

 Select New:- The New Workbook dialog box opens, and Blank Workbook is 

highlighted by default. 

 Click Create:- A new, blank workbook appears in the window. 

 

 

To insert text: 

 Left-click a cell to select it. Each rectangle in the worksheet is called a cell. As you select a 

cell, the cell address appears in the Name Box. 

 Enter text into the cell using your keyboard. The text appears in the cell and in the formula 

bar. 

Cell addresses 

Each cell has a name, or a cell address, based on the column and row where it is located. For 

example, this cell is C3 because it is where column C and row 3 intersect. 

 
 

To edit or delete text: 

 Select the cell. 

 Press the Backspace key on your keyboard to delete text and make a correction. 
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 Press the Delete key to delete the entire contents of a cell. 

To save the workbook: 

 Left-click the Microsoft Office Button. 

 Select Save or Save As. 

 Save As allows you to name the file and choose a location to save the spreadsheet. 

Choose Save As if you'd like to save the file for the first time or if you'd like to save the file 

as a different name. 

 Select Save if the file has already been named. 

Formatting Your Spreadsheet 

 Inserting Columns 

 Inserting Rows 

 Deleting Columns 

 Deleting Rows 

 Resizing Columns 

 Resizing rows 

 

Excel formatting tips and techniques:-  

There are many formatting tools some are explained below:- 

 

To format text in bold or italics: 

 Left-click a cell to select it, or drag your cursor over the text in the formula bar to select it. 

 Click the Bold or Italics command. 

 

To format text as underlined: 

 Select the cell or cells you want to format. 

 Click the drop-down arrow next to the Underline command. 

 Select the Single Underline or Double Underline option. 

 

To change the font style 

 Select the cell or cells you want to format. 

 Left-click the drop-down arrow next to the Font Style box on the Home tab. 

 Select a font style from the list. 

 

To change the font size: 

 Select the cell or cells you want to format. 

 Left-click the drop-down arrow next to the Font Size box on the Home tab. 

 Select a font size from the list. 

 

To change the text color: 

 Select the cell or cells you want to format. 

 Left-click the drop-down arrow next to the Text Color command. A color palette will 

appear. 

 Select a color from the palette. 
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Introduction to functions:- 

A function is a predefined formula that performs calculations using specific values in a 

particular order. While you may think of formulas as being short mathematical equations, like 

2+2 or F2*C2, they can actually be very lengthy and involve complex mathematical 

calculations.  

 

One of the key benefits of functions is that they can save you time because you do not have to write 

the formula yourself. For example, you could use an Excel function called Average to quickly find 

the average of a range of numbers or the Sum function to find the sum of a cell range. 

 

 

The parts of a function: 

Each function has a specific order, called syntax, which must be strictly followed for the function to 

work correctly. 

Syntax order: 

1. All functions begin with the = sign. 

2. After the = sign, define the function name (e.g., Sum). 

3. Then there will be an argument. An argument is the cell range or cell references that 

are enclosed by parentheses. If there is more than one argument, separate each by a 

comma. 

An example of a function with one argument that adds a range of cells, A3 through A9: 

 
An example of a function with more than one argument that calculates the sum of two cell ranges: 

Excel's different functions 

There are many different functions in Excel 2007. Some of the more common functions 

include: 

Statistical functions: 

SUM: Adds a range of cells together 

AVERAGE: Calculates the average of a range of cells 

COUNT: Counts the number of chosen data in a range of cells 

MAX: Identifies the largest number in a range of cells 

MIN: Identifies the smallest number in a range of cells 

Financial functions: 

Interest rates 

Loan payments 

Depreciation amounts 

Date and time functions: 

DATE: Converts a serial number to a day of the month 

Day of Week 

DAYS360: Calculates the number of days between two dates based on a 360-day year 

TIME: Returns the serial number of a particular time 

HOUR: Converts a serial number to an hour 
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MINUTE: Converts a serial number to a minute 

TODAY: Returns the serial number of today's date 

MONTH: Converts a serial number to a month 

YEAR: Converts a serial number to a year 

Chart:- 

A chart is a tool you can use in Excel to communicate your data graphically. Charts allow your 

audience to more easily see the meaning behind the numbers in the spreadsheet, and to make 

showing comparisons and trends much easier. In this lesson, you will learn how 

to insert and modify Excel charts and see how they can be an effective tool for communicating 

information. 

Creating a chart 

Charts can be a useful way to communicate data. When you insert a chart in Excel, it appears in the 

selected worksheet with the source data by default. 

To create a chart: 

 Select the cells you want to chart, including the column titles and row labels. 

 Click the Insert tab. 

 Select one of the Chart options.  

 Select a type of chart from the list that appears. The chart appears in the worksheet. 

The real power in Excel lies in its ability to perform multiple 

mathematical calculations for you. One of the tools in Excel that you can use to perform these 

calculations is a Data tool called what-if analysis also known as Goal Seek. What-if analysis allows 

you to see the effect different values have in formulas.  

 

What-If Analysis Tools 

There are three What-If analysis tools that you can use. To access these, select the Data tab and 

locate the What-If Analysis command. If you click this command, a menu with three options 

appears.  

 

Goal seek is useful if you know the needed result but need to find the input value that will give you 

the desired result. In this example, we know the desired result (a $400 monthly payment) and are 

seeking the input value (the interest rate). 

 

Goal Seek 

To Use Goal Seek to Determine an Interest Rate: 

 Select the Data tab. 
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 Locate the Data Tools group. 

 Click the What-If Analysis command. A list of three options appears. 

 
  

 Select Goal Seek. A small dialog box appears. 

 Select the cell that you want to set to a specific value. In this example, we want to set B5, 

the Payment cell. 

 
  

 Insert the cursor in the next field. 

 Enter a value in the value field. In this example, type -$400. Since we‘re making a payment 

that will be subtracted from our loan amount, we have to enter the payment as a negative 

number. 

 
  

 Insert the cursor in the next field. 
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 Select the cell that you want to change. This will be the cell that tries various input values. 

In this example, select cell B4, which is the interest rate. 

 
  

 Click OK. 

 Then, click OK again. The interest rate appears in the cell. This indicates that a 7% interest 

rate will give us a $400 a month payment on a $20,000 loan that is paid off over five years, 

or 60 months. 

 
Working with graphic:- 

Microsoft Office Excel 2007 gives you the tools to create a variety of graphic objects—boxes, lines, 

circles, ovals, arcs, freeform polygons, text boxes, buttons, and a wide assortment of complex 

predefined shapes, clip art, and the new SmartArt graphics.  

Using the Shapes tools 

The Excel graphics tool chest contains many of the powerful capabilities of dedicated illustration 

programs. Using only the tools in the Shapes palette on the Ribbon, you can create lines, rectangles, 

and ovals; smooth and freeform curves; linked objects using connectors; basic and not-so-basic 

shapes, such as pentagons and lightning bolts; a variety of straight, curved, three-dimensional (3-

D), and multiheaded arrows; stars, emblems, and banners; and even a variety of callouts. 

Creating WordArt 

The WordArt button on the Insert tab opens a palette containing a number of fancy text styles you 

can employ to create impressive logos and headings. After you click the effect you want in the 

palette, a new WordArt graphic object appears on the worksheet. You can then type your text and 

modify the WordArt object using controls on the Format tab under Drawing Tools; this tab appears 

on the Ribbon when you select the WordArt object. 
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Creating SmartArt 

The SmartArt button on the Insert tab represents a significant new set of features in the 2007 

Microsoft Office system. SmartArt replaces the Organization Chart feature with all that and more—

a comparative cornucopia of new functionality and graphic complexity. SmartArt graphics are 

prepackaged sets of graphic objects designed to address a variety of presentation tasks, such as 

creating timelines and decision trees, illustrating procedural steps and relationships, and, yes, even 

creating organizational charts. 

 

MS POWERPOINT 2007 

Microsoft Office Button: The Microsoft Office button appears in the top left corner of the window 

and includes basic file functions such as New, Open, Save, and Print.  

Tabs: The many buttons and menu options required to create and edit presentations are grouped 

into seven distinct categories and accessible from tab-like buttons which appear across the top of 

the window. 

 Ribbon: The ribbon contains the buttons and menu options specific to each tab for creating and 

editing presentations. 

 Current Slide: The current slide appears in the middle of the screen and contains the contents of a 

particular PowerPoint slide.  

Outline or Slides Tab: The Slides tab displays thumbnails of all slides in a presentation. The 

Outline tab displays an automatically generated outline of the presentation. 

 Help button: The help button in the top right corner of the window provides access to an index of 

help topics as well as a key-word search of the extensive help files.  

 

 
Lower Toolbar: The lower toolbar allows easy toggling between viewing options and also displays 

the number of the slide currently on screen.  

 
 

Tabs and the Ribbon 
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The ribbon includes seven tabs to choose from. After selecting a tab, the ribbon will automatically 

update to display the appropriate menu options and buttons. The menu options and buttons are 

grouped by functional category into distinct toolbars. 

 More Options button to display a pop-up window with the full set of menu options and buttons for 

that category. The More Options button is square-shaped with an arrow.  

 
Home Tab 

The Home tab includes basic functions for creating and manipulating a presentation. The toolbars 

that make up the Home tab include Clipboard, Slides, Font, Paragraph, Drawing, and Editing. 

Example menu and button options include copying and pasting, adding a new slide, adjusting fonts 

and paragraph formatting, and basic drawing features. 

 
Insert Tab 

Use the Insert tab to add a wide variety of content into a presentation including tables, charts, 

images, links, text boxes, audio, and video. The toolbars that make up the Insert tab include Tables, 

Illustrations, Links, Text, and Media Clips. 

 
Design Tab 

The Design tab provides a variety of options for designing and formatting a presentation. Use the 

Design tab to manipulate the page setup, color themes, and backgrounds of a presentation. The 

toolbars that make up the Design tab include Page Setup, Themes, and Background. 

 
Animations Tab 

Use the Animations tab to add, customize, and preview animations and transitions between slides. 

The toolbars that make up the Animations tab include Preview, Animations, and Transition to This 

Slide. 
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Slide Show Tab 

Manage the settings for showing a presentation with the Slide Show tab. The toolbars that make up 

the Slide Show tab include Start Slide Show, Set Up, and Monitors. 

 
 

Review Tab 

The Review tab provides access to proofing features like spell check and also allows for embedding 

comments in a presentation. The toolbars that make up the Review tab include Proofing and 

Comments. 

 
 

View Tab 

The View tab presents a number of options to specify how to view a presentation such as hiding or 

displaying notes, hiding or displaying gridlines, zooming in and out, displaying in gray scale, and 

more. The toolbars that make up the View tab include Presentation Views, Show/Hide, Zoom, 

Color/Grayscale, Window, and Macros. 

 
 

Create a New Presentation 

To create a new presentation, 

 Click the Microsoft Office button and select New. The New Presentation pop-up window 

will appear, 

Choose to start with one of Microsoft‘s Installed Templates, Installed Themes, or a Blank 

presentation to create a customized presentation.  

 Click the Installed Themes menu option to browse through the available graphical themes. 

Select one that will work for the presentation.  
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 Click the Create button in the lower right-hand corner.  

Or 

To create a completely custom-designed presentation,  

 Select the Blank and recent menu option.  

 Click the Blank Presentation button and then the Create button in the lower right-hand 

corner.  

 
 

 

Design a Presentation 

PowerPoint includes a number of ready-made design themes. These themes serve as the basis for 

the graphic design of a presentation. Each theme consists of a background design, placeholder 

layouts, a color palette, and font styles. To browse through the available themes, click the Design 

tab in the ribbon.. Click a particular theme to apply it to the presentation. 

 

 
To skip the ready-made themes in order to create a custom-designed presentation, 

 Select the Design tab in the ribbon.  

 Click the Background Styles menu to choose the background.  

 Click the Colors, Fonts, and Effects menus in the Themes toolbar to customize the design of 

the presentation.  

 To customize a ready-made theme, click an element within a slide.  

 Select the Design tab and then choose from the various options available from the Colors, 

Fonts, and Effects menus in the Themes toolbar.  

 Adjust the Background using the Background Styles menu in the Background toolbar. 

Insert a New Slide 

To insert a new slide into a presentation,  

 Click the Home tab in the ribbon.  

 In the Slides toolbar, select the New Slide button  
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Save the Presentation 

To save a presentation,  

Click the Microsoft Office button and choose Save As.  

 

Charts 

Charts and graphs are an effective way to present information than a simple list of numbers. 

PowerPoint 2007 is fully integrated with the spreadsheet tools of Excel 2007, making it very easy to 

create a chart from scratch or to import data from an existing spreadsheet. 

 

Creating Charts 

1. Select the slide where you want the chart to appear. 

2. In the Insert tab, under the Illustrations group, click on CHART  to open the Insert 

Chart dialog. 

 
3. Select the type of chart from the category list on the left, or simply scroll through the gallery 

on the right to view all the available charts. Once you have made your selection, click OK. 

4. The chart will appear on your slide, and Excel will open as a split screen with dummy data 

already filled in. 

5. Add your data and labels to the Excel spreadsheet and the chart will be automatically 

updated on your slide. 

6. When finished, click the  in the upper right hand corner of Excel to close the worksheet.. 
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Animation  
PowerPoint allows you to animate objects or specific content within a slide and also to add 

animated transitions between slides. Transitions are a common and easy way to liven up a 

presentation.  

 

Add Transitions  
To add a consistent transition between each slide throughout the presentation, follow these 

instructions.  

1. Click the View tab and click the Slide Master button.  

2. In the left-hand Slides tab, select the first slide which is numbered ―1.‖  

3. Click the Animations tab.  

4. In the Transition to This Slide toolbar, browse through the transition options and click the 

appropriate choice. Place the mouse over each option to preview the transition within the slide 

currently on screen.  

5. When satisfied with the transition, click the Slide Master tab and then the Close Master View 

button.  

 
 

Add Animation  
With PowerPoint, you can animate virtually any object or specific content that appears on a slide.  

 To animate an object or content, select it.  

 Click the Animations tab.  

 Select from the menus and buttons available in the Animations toolbar.  

 After selecting the appropriate animation settings, use the Preview button to see the 

animation in. 

 

Audio  

 To add audio to a presentation 

1. Click the Insert tab.  

2. Then click the Sound button.  

3. Navigate to the correct audio clip and select it.  

4. A pop-up window will ask if the audio should play Automatically or When Clicked.  

5. An audio icon will automatically appear on the slide. To preview the audio, right click the audio 

icon and select    Preview.  

 

Inserting and Format Picture Tab:- 

You can even insert the image in your presentation. To insert click on insert option and then on 

picture, a window will open you can insert the picture from any desired location. 

After you insert an image the Picture Tools - Format tab will automatically appear.  

Adjust Picture Settings 
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The Adjust group on the Picture Tools tab allows you to adjust 

the brightness and contrast of your image. You can also use 

the recoloring options to change the tint of your picture. 

 

Borders and Effects 

 
With the Picture Styles group you can add some interesting effects to your images, including 

regular borders and shaped borders, shadows and reflections, and 3-D rotation options. PowerPoint 

comes with a number of built-in options, or you can customize your own using the drop down 

Picture Shape, Picture Border, and Picture Effects menus on the right. 

Arranging, Aligning & Grouping Images 

Arranging 
PowerPoint allows you to overlap objects, so that for example you 

could have a text box or a callout over an image, or two images that 

overlap each other, or several solid shapes and lines arranged to make 

an interesting background on a slide master. 

Aligning 
You can always move objects by clicking and dragging them, 

but if you want to be more exact with your placement, use the 

options under the Align menu. You can use this to place 

objects to the right, left, top, bottom, and center of the slide, make 

sure the object is both horizontally or vertically centered by 

using the distribute options, or display a grid to help with your 

manual placements. 

Grouping 
The final option in the Arrange section is the Group button. 

This button is used to combine objects into one so that they 

can be moved and edited all at once.  

Cropping & Resizing Images 
You can also use the Crop tool to remove unnecessary parts of your images. Cropping resizes an 

image by hiding horizontal or vertical edges. 

To crop an image, click the Crop button.  

 

Inserting animated pictures 

1. On the Insert menu, point to Movies and Sounds, click Movie from File, locate the folder that 

contains the file you want, and then double-click the file. 

(A movie or .gif file that you've added to Clip Organizer is found in the Clip Organizer folder 

within the My Pictures folder on your hard disk. Or, go to the original location for these files.) 

2. When a message is displayed, do one of the following: 

 To play the movie or GIF automatically when you go to the slide, click automatically. 

 To play the movie or GIF only when you click it, click When Clicked. 
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javascript:AppendPopup(this,'727122714_2')
http://gethelp.library.upenn.edu/images/workshops/biomed/ppt/pictools_rotate.gif
http://gethelp.library.upenn.edu/images/workshops/biomed/ppt/pictools_rotate.gif
http://gethelp.library.upenn.edu/images/workshops/biomed/ppt/pictools_rotate.gif
http://gethelp.library.upenn.edu/images/workshops/biomed/ppt/pictools_rotate.gif


 
B.Com 1st  Year        Subject- Introduction to Computer Fundamental and PC 
Software 
 

 

45, Anurag Nagar, Behind Press Complex, Indore (M.P.) Ph.: 4262100, www.rccmindore.com 
78 

 

Inserting Sounds:   

PowerPoint 2007 provides some videos and sound clips that are free to use in the Clip Manager. 

You can also use clips from other sources, such as the Web, a CD of sound effects, or sounds you 

create yourself. 

You can insert sound using following:- 

 Inserting sounds using the Clip Organizer 

 Inserting sounds from a file 

 Recording your own sounds 

 

Adding Notes 

There are two ways to insert notes in PowerPoint. 

1. To insert short notes: In the Normal view, click on the Notes box at the bottom of your screen 

and type your text. 

 

2. To insert longer notes: Click on the View tab. Under Presentation Views select the Notes 

Page button. Type your notes in the space that appears below your slide. 

 

  

Inserting Headers & Footers 

 

To add a header and footer, click on the Insert tab, then on the Header & Footer button. The Date 

& Time and Slide Number buttons will bring up the same dialog box. 

 
1. Fixed and Automatic Dates - PowerPoint gives you the option to add either a fixed date and 

time, which will remain the same, or a date and time that automatically update. If you choose to 

have a date and time that automatically update, the date and time will always match the date and 

time that you run your slide show. 

2. Slide Number - Check this box to show the slide number. 

3. Footer - Check the Footer box and add text to have text appear at the bottom of the slide. 

4. Apply/Apply To All - To insert your chosen elements into your slide, select Apply to have the 

information appear only on your current slide, or Apply To All to have it appear on every slide. If 

any of the information is repeated on the title slide, check the Don't show on title slide box to 

avoid repeating the information. 
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5. Preview - The Preview box shows you where on your slide the information will appear. You can 

not change this from within this screen, but once you insert the information you can click and drag 

the box anywhere in your slide, just like any other text box. 

Note: If you chose to Apply To All, moving the text box in one slide will not effect the placement of 

the information in the rest of your slides. 

6. Notes and Handouts - Under this tab, you can choose your header and footer preferences for 

your handouts. 

 

WordArt overview 

WordArt allows you to add special text effects to your document. For example, you can stretch a 

title, skew text, make text fit a preset shape, or apply a gradient fill. This WordArt becomes an 

object that you can move or position in your document to add decoration or emphasis. You can 

modify or add to the text in an existing  

WordArt object whenever you want. 

 

 
Layering Art Objects:- 

There are two main reasons you may want to layer objects in a PowerPoint presentation. 

1. Layering objects gives you the freedom to arrange your presentation the way we 

want it to look. 

2. Layering lets you take advantage of all of the white space in your presentation. Text 

boxes in particular take up a lot of room. By layering objects, you can use all of the 

space on a slide without changing the position of other objects. 

Layering Objects in PowerPoint 

Suppose you add four boxes to your PowerPoint presentation; first a red one, then green, then blue, 

then yellow. Each box represents an object. When you add a new object to a PowerPoint 

presentation, the application automatically places the newest objects on top of older objects. If you 

add the boxes in the order mentioned above, the layering of the objects will look like this: 
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In the Drawing section, locate and click on the button titled Arrange to arrange it according to 

you. 

 
There are four options titled: 

1. Bring to Front 

2. Send to Back 

3. Bring Forward 

4. Send Backward 

 

 

 

 

 

 

 


